Clerk Outage History
25 incidents reported. Data sourced from the official Clerk status page.
25
Total Incidents
8
Major/Critical
17
Minor
25
Resolved
July 2026
Elevated API Errors
minorJul 16, 01:04 PM→Jul 16, 02:01 PMresolved
Jul 16, 02:01 PM
resolved — We have confirmed that error rates have returned to baseline.
Jul 16, 01:45 PM
monitoring — We've deployed a fix and are seeing error rates decrease. We are monitoring.
Jul 16, 01:27 PM
investigating — We're continuing to investigate.
+2 more updates
Increased latency on our APIs
minorJul 16, 07:56 AM→Jul 16, 07:58 AMresolved
Jul 16, 07:58 AM
resolved — There was a service degradation on our caching layer that affected the latency of our APIs. The caching layer is back to normal and latency dropped to normal levels.
Jul 16, 07:56 AM
investigating — There is increased latency on our APIs. We are investigating.
Elevated errors while configuring domains
majorJul 12, 10:05 PM→Jul 13, 01:37 AMresolved
Jul 13, 01:37 AM
resolved — All domains have been processed from this incident.
Jul 12, 11:10 PM
monitoring — The underlying issue has been resolved, a downstream provider incident.
Domains which failed to be provisioned are now being reprocessed and succeeding.
We are continuing to monitor.
Jul 12, 10:05 PM
monitoring — We are observing elevated errors while provisioning domains
Elevated errors in Account Portal
minorJul 9, 08:38 PM→Jul 9, 08:43 PMresolved
Jul 9, 08:43 PM
resolved — The underlying issue has been identified and the Account Portal is now fully functioning again.
Jul 9, 08:38 PM
investigating — We are observing evaluated errors in account portal and actively investigating the source of the problem
Delay in webhook delivery
minorJul 1, 05:12 PM→Jul 1, 05:26 PMresolved
Jul 1, 05:26 PM
resolved — We have identified the cause of the delays and our mitigations have been successful. We are continuing to monitor webhook delivery.
Jul 1, 05:12 PM
investigating — We are investigating delays in webhook delivery. We have deployed mitigations and are continuing to monitor.
June 2026
SVGs are not loading properly
minorJun 18, 08:21 PM→Jun 18, 08:23 PMresolved
Jun 18, 08:23 PM
resolved — A fix has been published and confirmed it's now resolving SVGs correctly
Jun 18, 08:22 PM
monitoring — A fix has been deployed and we're seeing improved rates of resolution on the SVGs
Jun 18, 08:21 PM
investigating — SVGs are not loading properly, the team is investigating a fix
Dashboard analytics not loading properly
minorJun 18, 03:43 PM→Jun 18, 04:18 PMresolved
Jun 18, 04:18 PM
resolved — Services are up and running.
Jun 18, 04:17 PM
monitoring — A fix has been implemented, we are currently monitoring the affected services.
Jun 18, 04:16 PM
identified — Issue identified
+1 more updates
Elevated errors on Platform-API
minorJun 15, 03:44 PM→Jun 15, 03:26 PMresolved
Jun 15, 03:59 PM
resolved — Systems are fully operational
Jun 15, 03:44 PM
investigating — Elevated errors were observed in platform API when communicating with an upstream service
Elevated errors or delays for Clerk application going live
minorJun 12, 02:48 PM→Jun 12, 03:29 PMresolved
Jun 12, 03:29 PM
resolved — All systems are operational
Jun 12, 03:13 PM
monitoring — A fix has been implemented by the upstream provider.
We are monitoring the results
Jun 12, 02:48 PM
identified — An upstream provider has a partial outage. Errors or delays might be encountered when a Clerk application goes live.
We are monitoring the situation.
Analytics API I/O timeouts
majorJun 9, 09:56 PM→Jun 9, 10:37 PMresolved
Jun 9, 10:37 PM
resolved — Between 21:21 and 21:56 UTC on June 9, 2026, a portion of requests to our Analytics service failed and Dashboard charts may have failed to load. The cause was a database connection that had been silen...
Jun 9, 10:11 PM
monitoring — We've mitigated a connection issue with the Analytics API and are now monitoring.
Jun 9, 09:56 PM
investigating — Endpoints that use analytics (such as dashboard charts) are encountering timeouts. We are investigating.
May 2026
Elevated Errors in APIs
minorMay 28, 07:16 PM→May 28, 08:32 PMresolved
May 28, 08:32 PM
resolved — APIs have returned to normal operation.
May 28, 07:30 PM
monitoring — We have deployed a mitigation to our APIs and observed errors return to a normal level. We are continuing to investigate and monitor.
May 28, 07:16 PM
investigating — We are investigating elevated level of internal errors in APIs.
Elevated 500 rates on API responses
majorMay 26, 09:19 PM→May 26, 10:26 PMresolved
May 26, 10:26 PM
resolved — The root cause has been identified and addressed. We will continue to monitor going forward.
May 26, 10:08 PM
monitoring — We have deployed a fix for this issue and our services appear to have returned to normal operation. We continue to monitor.
May 26, 10:00 PM
investigating — We have deployed a fix and are observing rapid decline in error rates. We continue to monitor the situation.
+4 more updates
Issue with Provisioning Domains
minorMay 22, 03:48 PM→May 22, 09:43 PMresolved
May 22, 09:43 PM
resolved — Systems are back to normal.
May 22, 04:53 PM
monitoring — Our upstream provider has implemented a fix for domain provisioning. We are seeing signs of recovery and are continuing to monitor the situation.
May 22, 03:48 PM
investigating — There is an ongoing issue with one of our upstream providers which is impacting the provisioning of domains.
SCIM services are facing intermittent errors
minorMay 14, 08:37 PM→May 14, 09:05 PMresolved
May 14, 09:05 PM
resolved — The upstream provider marked the issue as resolved, we're continuing to monitor the database, but no error was observed.
May 14, 08:47 PM
monitoring — We're monitoring the database health, no error has been found on the last 10 minutes.
May 14, 08:37 PM
investigating — Our upstream database provider is facing issues with a specific region where our database is deployed, we're currently seeing intermittent errors on the SCIM services. The rest of clerk is not affecte...
Account Portal not Redirecting
majorMay 11, 03:00 PM→May 11, 05:19 PMresolved
May 11, 05:19 PM
resolved — The issue has been resolved.
May 11, 03:30 PM
monitoring — We have deployed a mitigation and are observing.
May 11, 03:00 PM
investigating — Some customers are encountering an issue where the root route at the Accounts Portal is returning 404 and not redirecting to the appropriate page.
Sign-in Clerk components unavailable for some domains
minorMay 8, 11:02 AM→May 8, 02:40 PMresolved
May 8, 02:40 PM
resolved — We continue to work with our DNS provider to discover the source of the issue. We currently believe approximately 0.37% of traffic was impacted by being unable to resolve DNS of the CDN that provides ...
May 8, 11:38 AM
monitoring — We have observed that failures to load Clerk JS (reported by [dashboard.clerk.com](http://dashboard.clerk.com)) last occurred 30minutes ago, and this would correlate with failures reported from Clerk ...
May 8, 11:02 AM
investigating — We are currently investigating an issue where Clerk JS cannot be downloaded, preventing sign in or sign up when using Clerk components. We believe this is related to DNS [clerk.[your_domain].com](http...
Dashboard down
criticalMay 8, 01:39 AM→May 8, 02:17 AMresolved
May 8, 02:17 AM
resolved — We have identified the root cause and are putting in place mitigations to ensure this does not happen in the future.
May 8, 01:48 AM
monitoring — The Dashboard has been restored and we are currently monitoring the issue.
May 8, 01:39 AM
investigating — Dashboard down
April 2026
Increased error rate
minorApr 27, 06:43 PM→Apr 27, 09:19 PMresolved
Apr 27, 09:49 PM
resolved — The issue has been resolved
Apr 27, 07:15 PM
monitoring — A fix has been deployed and we're still monitoring closely. We'll update again once we've confirmed full recovery.
Apr 27, 06:43 PM
investigating — We are currently investigating an increased error rate affecting our APIs. We will provide updates as more information becomes available.
/handshake endpoint failures
minorApr 26, 07:39 AM→Apr 26, 07:26 AMresolved
Apr 26, 07:39 AM
resolved — The issue has been resolved
Apr 26, 07:39 AM
identified — Visitors with stale authentication tokens in server-rendered applications are seeing failures on our /handshake endpoint.
Intermittent Issues with Development Services
majorApr 25, 08:00 AM→Apr 25, 02:52 PMresolved
Apr 25, 02:52 PM
resolved — Development services are back to normal.
Apr 25, 08:00 AM
investigating — Intermittent disruptions as part of expected infrastructure updates.
Partial Outage on Platform API
majorApr 23, 09:12 AM→Apr 22, 07:03 AMresolved
Apr 23, 09:12 AM
resolved — All Platform API functionality has been fully restored.
Apr 23, 09:12 AM
monitoring — We upgraded the SDK to the latest version and are continuing to monitor the situation.
Apr 23, 09:12 AM
identified — We identified a bug in a third-party provider that was using an older SDK version. This issue affected users attempting to create or update applications through the Platform API.
+1 more updates
Satellite domain failures
minorApr 8, 03:42 AM→Apr 8, 04:06 AMresolved
Apr 8, 04:06 AM
resolved — The incident has resolved.
Apr 8, 03:50 AM
monitoring — Revert has been deployed and systems have stabilized. We will continue to monitor.
Apr 8, 03:42 AM
identified — Beginning 1:44am UTC: A subset of customers using satellite domains began experiencing failures. The issue has been identified and is being reverted.
March 2026
Degraded perfomance in webhooks
minorMar 23, 12:32 PM→Mar 23, 01:00 PMresolved
Mar 23, 01:00 PM
resolved — Webhook delivery is operational, and the delays caused by a temporary performance degradation have been resolved.
Mar 23, 12:32 PM
investigating — We've noticed small delays in a small subset of webhooks. We are currently investigating
Degraded performance
minorMar 20, 10:09 AM→Mar 20, 11:03 AMresolved
Mar 20, 05:24 PM
resolved — The root cause was a DDoS attack against our infrastructure. It has been fully mitigated and all systems are back to normal.
Mar 20, 10:32 AM
monitoring — Performance has stabilized after our earlier mitigations. We're continuing to monitor closely and will give a final update once we've confirmed full recovery.
Mar 20, 10:19 AM
monitoring — We've found the source of the performance issue and applied mitigations. Systems are stabilizing and we're still monitoring closely. We'll update again once we've confirmed full recovery.
+1 more updates
JWT Templates increased 422 errors
majorMar 11, 08:24 PM→Mar 11, 08:34 PMresolved
Mar 11, 08:34 PM
resolved — The root cause was identified and the issue was resolved at 20:24:10 UTC.
Mar 11, 08:24 PM
identified — We're observing JWT Templates are facing increased 422 errors when organization ID is present. The fix has been identified and should be resolved shortly
Related Incident Histories
Get Clerk Outage Alerts
Be the first to know when Clerk go down.