Cloudflare Outage History
50 incidents reported. Data sourced from the official Cloudflare status page.
50
Total Incidents
3
Major/Critical
40
Minor
50
Resolved
June 2026
Network Performance Issues in Mexico
noneJun 9, 01:30 AM→Jun 9, 01:30 AMresolved
Jun 9, 02:46 AM
resolved — Connectivity errors (HTTP 500s) and elevated latency observed due to a hardware failure between 01:32 - 01:36 UTC 2026-06-09. Cloudflare has mitigated the issue.
Increased HTTP 500 errors for R2
minorJun 8, 11:43 PM→Jun 9, 12:50 AMresolved
Jun 9, 02:24 AM
resolved — This incident has been resolved.
Jun 9, 12:09 AM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 8, 11:43 PM
investigating — Some Cloudflare R2 users may have seen increased errors when using R2
Elevated 500 errors on CF1 SaaS Integrations API
criticalJun 8, 05:36 PM→Jun 8, 10:41 PMresolved
Jun 8, 10:41 PM
resolved — This incident has been resolved.
Jun 8, 10:25 PM
monitoring — We are continuing to monitor for any further issues.
Jun 8, 07:58 PM
monitoring — We are continuing to monitor for any further issues.
+2 more updates
RealtimeKit performance issues
minorJun 8, 04:34 PM→Jun 8, 06:23 PMresolved
Jun 8, 06:23 PM
resolved — This incident has been resolved.
Jun 8, 05:54 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 8, 04:56 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
GraphQL elevated latency
minorJun 8, 03:47 PM→Jun 8, 04:57 PMresolved
Jun 8, 04:57 PM
resolved — This incident has been resolved.
Jun 8, 04:14 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 8, 03:47 PM
investigating — Cloudflare has identified an issue where some customers may experience latency querying the GraphQL API. We are working to analyze and mitigate this problem. More updates to follow shortly.
Increased HTTP 500 errors for R2 in WEUR region
noneJun 8, 04:00 PM→Jun 8, 04:00 PMresolved
Jun 8, 04:30 PM
resolved — Cloudflare R2 users may have seen increased errors when reading data from buckets stored in WEUR.
R2 and Teams' payments failing during Checkout flow
minorJun 8, 10:05 AM→Jun 8, 01:30 PMresolved
Jun 8, 01:30 PM
resolved — This incident has been resolved.
Jun 8, 12:42 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 8, 10:06 AM
identified — We are continuing to work on a fix for this issue.
+1 more updates
Cloudflare Dashboard and Cloudflare API service issues
minorJun 8, 10:46 AM→Jun 8, 11:10 AMresolved
Jun 8, 11:10 AM
resolved — This incident has been resolved.
Jun 8, 10:52 AM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 8, 10:46 AM
investigating — Cloudflare is investigating issues with Cloudflare Dashboard and related APIs. These issues do not affect the serving of cached files via the Cloudflare CDN or other security features at the Cloudflar...
DNS Resolver issue
minorJun 8, 05:56 AM→Jun 8, 09:35 AMresolved
Jun 8, 09:35 AM
resolved — This incident has been resolved.
Jun 8, 06:32 AM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 8, 05:56 AM
investigating — Cloudflare is investigating an issue with DNS resolution for `.co` and `.xyz` TLDs in Dallas, US. We are working to analyze and mitigate this problem. More updates to follow shortly.
Network Connectivity Issues observed in Dallas (DFW)
minorJun 6, 08:45 PM→Jun 6, 08:45 PMresolved
Jun 7, 02:47 AM
resolved — Connectivity errors (HTTP 500s) and elevated latency observed due to a hardware failure between 20:45 - 21:05 UTC 2026-06-06. Cloudflare have mitigated the issue.
TLS Connectivity Issues Affecting Subset of Let's Encrypt Certificates
minorJun 5, 05:22 PM→Jun 6, 03:53 AMresolved
Jun 6, 03:53 AM
resolved — This incident has been resolved.
Jun 6, 03:42 AM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 5, 05:28 PM
identified — Cloudflare has identified an issue affecting a subset of Let's Encrypt certificates, in which unsupported CA bundling may result in TLS connectivity issues for some visitors. Customers requiring immed...
+1 more updates
Cloudflare API service issues
minorJun 5, 02:58 PM→Jun 5, 07:48 PMresolved
Jun 5, 07:48 PM
resolved — This incident has been resolved.
Jun 5, 02:58 PM
investigating — Cloudflare is investigating issues with Cloudflare related APIs.
These issues do not affect the serving of cached files via the Cloudflare CDN or other security features at the Cloudflare Edge.
Some...
WARP connectivity
minorJun 5, 09:43 AM→Jun 5, 10:35 AMresolved
Jun 5, 10:35 AM
resolved — This incident has been resolved.
Jun 5, 09:43 AM
investigating — Cloudflare is investigating issues with Cloudflare WARP and Cloudflare Zero Trust. Cloudflare WARP and Zero Trust users may experience connectivity issues or a degraded Internet experience.
Cloudflare Analytics API latency out of AMS
minorJun 4, 03:21 PM→Jun 4, 04:36 PMresolved
Jun 4, 04:36 PM
resolved — This incident has been resolved.
Jun 4, 03:21 PM
investigating — Cloudflare is investigating latency issues with Cloudflare Analytics API, specifically affecting the Amsterdam (AMS) region. These issues do not affect other API services nor the serving of cached fil...
Network Performance Issues in TLV
minorJun 2, 09:01 PM→Jun 4, 04:25 PMresolved
Jun 4, 04:25 PM
resolved — This incident has been resolved.
Jun 3, 04:44 PM
identified — We have identified the source of this issue and are working toward a fix. We have determined that most customers will not be affected by this issue.
Jun 3, 03:39 PM
investigating — We are continuing to investigate this issue.
+5 more updates
Increased 5XX error rate on Browser rendering
minorJun 3, 09:31 AM→Jun 4, 03:37 PMresolved
Jun 4, 03:37 PM
resolved — This incident has been resolved.
Jun 3, 02:58 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 3, 12:50 PM
investigating — We are currently investigating this issue.
+3 more updates
Cloudflare Analytics API latency out of AMS
minorJun 4, 09:08 AM→Jun 4, 09:27 AMresolved
Jun 4, 09:27 AM
resolved — This incident has been resolved.
Jun 4, 09:08 AM
investigating — Cloudflare is investigating latency issues with Cloudflare Analytics API, specifically affecting the Amsterdam (AMS) region. These issues do not affect other API services nor the serving of cached fil...
Network Congestion in Frankfurt
noneJun 4, 06:59 AM→Jun 4, 06:59 AMresolved
Jun 4, 06:59 AM
resolved — Cloudflare observed network congestion in Frankfurt from 05:53 UTC to 06:08 UTC. The issue is now resolved.
Issue with Bot Management Traffic Categorization For Verified Bots
minorJun 3, 10:31 PM→Jun 4, 12:12 AMresolved
Jun 4, 12:12 AM
resolved — This incident has been resolved.
Jun 4, 12:07 AM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 3, 10:36 PM
identified — The cause of this issue has been identified and a fix is being implemented.
+1 more updates
Audit Log Delays
minorJun 3, 07:58 PM→Jun 3, 09:25 PMresolved
Jun 3, 09:25 PM
resolved — An effective fix has been implemented and this incident is now resolved.
Jun 3, 09:15 PM
identified — The cause of this issue has been identified and a fix is being implemented.
Jun 3, 07:59 PM
investigating — We are continuing to investigate this issue.
+1 more updates
Customers are facing an increase in API errors when requesting Audit Logs
minorJun 3, 01:30 PM→Jun 3, 02:29 PMresolved
Jun 3, 02:29 PM
resolved — This incident has been resolved.
Jun 3, 01:30 PM
investigating — We are currently investigating this issue.
Bot Management - Increased False Positives
minorJun 3, 02:26 AM→Jun 3, 05:58 AMresolved
Jun 3, 05:58 AM
resolved — This incident has been resolved.
Jun 3, 04:50 AM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 3, 02:38 AM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Issue with TLS certificates using Lets Encrypt CA
minorJun 2, 12:25 AM→Jun 3, 05:01 AMresolved
Jun 3, 05:01 AM
resolved — This incident has been resolved.
Jun 2, 12:25 AM
identified — Cloudflare has identified an issue affecting a subset of Let's Encrypt certificates, in which unsupported CA bundling may result in TLS connectivity issues for some visitors. Customers requiring immed...
Browser Run
minorJun 2, 07:18 PM→Jun 2, 08:48 PMresolved
Jun 2, 08:48 PM
resolved — This incident has been resolved.
Jun 2, 07:47 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 2, 07:25 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Customers with traffic using China Network may see an increased in Challenge failures
minorJun 2, 04:48 AM→Jun 2, 05:28 PMresolved
Jun 2, 05:28 PM
resolved — This incident has been resolved.
Jun 2, 07:16 AM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 2, 06:08 AM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Cloudflare Access Configuration Delays
minorJun 2, 01:55 PM→Jun 2, 02:28 PMresolved
Jun 2, 02:28 PM
resolved — This incident has been resolved.
Jun 2, 02:24 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 2, 01:55 PM
investigating — Cloudflare is aware of and investigating issues with Cloudflare Access. Customers may observe delays when making configuration changes. We are currently working on a resolution. More updates to follow...
Network performance issues in US Eastern region
noneJun 2, 12:00 PM→Jun 2, 12:00 PMresolved
Jun 2, 02:39 PM
resolved — Between 13:39 and 14:06 on June 2nd, 2026 Cloudflare identified and mitigated a network performance issue specifically affecting the US Eastern region.
Users may have experienced increased latency o...
Cloudflare is investigating an increased level of HTTP 5xx errors in the Miami and Bogota areas
minorJun 2, 03:24 AM→Jun 2, 04:32 AMresolved
Jun 2, 04:32 AM
resolved — This incident has been resolved.
Jun 2, 03:24 AM
investigating — Cloudflare is investigating an increased level of HTTP 5xx errors between Miami and Bogota. We are working to analyse and mitigate this problem. More updates to follow shortly.
Increased HTTP errors in Miami and Bogota
noneJun 2, 01:30 AM→Jun 2, 01:30 AMresolved
Jun 2, 03:19 AM
resolved — Cloudflare saw an Increased HTTP errors in Miami and Bogota from 01:50 to 02:55 UTC. This issue is now resolved
Cloudflare Dashboard and Cloudflare API service issues
minorJun 1, 05:48 PM→Jun 2, 01:18 AMresolved
Jun 2, 01:18 AM
resolved — This incident has been resolved.
Jun 1, 09:30 PM
identified — The issue has been identified and a fix is being implemented.
Jun 1, 05:48 PM
investigating — Cloudflare is investigating issues with Cloudflare APIs that are specifically impacting OAuth/Wrangler API calls. These issues do not affect the serving of cached files via the Cloudflare CDN or other...
Possible Network Congestion in US Eastern region
minorJun 1, 08:59 PM→Jun 1, 10:38 PMresolved
Jun 1, 10:38 PM
resolved — This incident has been resolved.
Jun 1, 09:34 PM
monitoring — We are continuing to monitor for any further issues.
Jun 1, 09:31 PM
monitoring — A fix has been implemented and we are monitoring the results.
+2 more updates
May 2026
Custom Hostname API issue
minorMay 31, 01:06 AM→Jun 2, 06:35 PMresolved
Jun 2, 06:35 PM
resolved — This incident has been resolved.
Jun 2, 01:16 AM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 1, 12:47 AM
identified — The issue has been identified .
+3 more updates
Durable Objects and Log Explorer issues
minorMay 31, 06:42 AM→May 31, 03:20 PMresolved
May 31, 03:20 PM
resolved — This incident has been resolved.
May 31, 07:30 AM
monitoring — A fix has been implemented and we are monitoring the results.
May 31, 07:28 AM
investigating — Log Explorer is experiencing intermittent delays with recent logs showing up in queries.
+1 more updates
Issues with TLS certificates using Lets Encrypt CA
minorMay 31, 03:16 AM→May 31, 08:55 AMresolved
May 31, 08:55 AM
resolved — This incident has been resolved.
May 31, 06:41 AM
identified — The issue has been identified and a fix is being implemented.
Customers are advised to change to a different Certificate Authority as a workaround.
May 31, 03:16 AM
investigating — Cloudflare is investigating issues with Let's Encrypt certificates. Some visitors may experience TLS connectivity issues due to potentially unsupported CA bundling for a subset of Cloudflare customers...
Increased errors when accessing Workers secrets
minorMay 30, 02:51 PM→May 30, 07:52 PMresolved
May 30, 07:52 PM
resolved — This incident has been resolved.
May 30, 02:52 PM
investigating — We are continuing to investigate this issue.
May 30, 02:51 PM
investigating — Cloudflare Secrets Store users may see increased errors when accessing secrets
Pages upload failures
minorMay 28, 02:42 PM→May 29, 08:08 PMresolved
May 29, 08:08 PM
resolved — This incident is now resolved.
May 28, 08:45 PM
monitoring — We have identified the cause of this issue and applied a fix. We are currently monitoring the results.
May 28, 02:42 PM
investigating — Cloudflare is aware of and investigating an issue impacting a subset of Pages uploads. Some customers may experience their uploads returning a 502 error.
We are working to analyse and mitigate this pr...
HTTP Rollups delays
minorMay 29, 04:41 PM→May 29, 05:24 PMresolved
May 29, 05:24 PM
resolved — This incident has been resolved.
May 29, 04:41 PM
investigating — Reporting and analytics for HTTP requests rollups is delayed. Edge services are still fully operational, just analytics are delayed. We are working to mitigate this problem. More updates to follow sho...
Cloudflare Notifications issues
minorMay 29, 07:32 AM→May 29, 07:32 AMresolved
May 29, 07:32 AM
resolved — This incident has been resolved.
May 29, 07:32 AM
monitoring — Cloudflare is investigating issues with the Cloudflare Notifications product. Some alerts might be temporarily delayed.
Impact is restricted to the notification functionality and it does not affect a...
Cloudflare Tunnel Connectivity Issues via Anchorage (ANC) from 2026-05-14 to 2026-05-28
majorMay 28, 12:13 PM→May 28, 12:18 PMresolved
May 28, 12:18 PM
resolved — This incident has been resolved.
May 28, 12:13 PM
monitoring — Between May 14th and May 28th, 2026, an issue with network routing impacted a subset of Cloudflare Tunnel connections routing through our Anchorage, AK (ANC) point of presence. This issue has been ful...
Elevated number of 5xx errors in Dallas Texas
noneMay 28, 01:00 AM→May 28, 01:00 AMresolved
May 28, 01:52 AM
resolved — Between 01:17 UTC - 01:28 UTC, customers reaching Dallas Texas region would have experienced an elevated number of 5xx errors. This incident is now resolved
Container Registry Unavailability
noneMay 27, 09:30 PM→May 27, 09:30 PMresolved
May 27, 09:53 PM
resolved — Customers might have seen intermittent unavailability with the container managed registry
Cloudflare Analytics availability degraded
minorMay 27, 11:14 AM→May 27, 05:15 PMresolved
May 27, 05:15 PM
resolved — This incident has been resolved.
May 27, 03:28 PM
monitoring — A fix has been implemented and we are monitoring the results.
May 27, 11:36 AM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
AI Gateway Prompts not scanned for DLP
minorMay 26, 07:31 PM→May 26, 07:52 PMresolved
May 26, 07:52 PM
resolved — This incident has been resolved.
May 26, 07:31 PM
investigating — Cloudflare is investigating issues about not correctly scanning certain AI gateway prompts for DLP
Slow build start time in Workers Builds
minorMay 25, 04:05 PM→May 25, 05:14 PMresolved
May 25, 05:14 PM
resolved — This incident has been resolved.
Customers with builds that timed out can retry their build in the Dashboard
May 25, 04:44 PM
monitoring — A fix has been implemented and we are monitoring the results.
May 25, 04:36 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
API Errors
minorMay 23, 07:41 PM→May 24, 08:30 PMresolved
May 24, 08:30 PM
resolved — This incident has been resolved.
May 23, 08:57 PM
monitoring — A fix has been implemented and we are monitoring the results.
May 23, 07:41 PM
investigating — We are investigating elevated error rates for API requests. Customers may experience failures when making API calls.
Cloudflare Zero Trust Gateway Issues — FedRAMP High
majorMay 23, 07:25 PM→May 23, 07:37 PMresolved
May 23, 07:37 PM
resolved — This incident has been resolved.
May 23, 07:35 PM
monitoring — A fix has been implemented and we are monitoring the results.
May 23, 07:29 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Audit Log Delays
minorMay 22, 04:55 PM→May 22, 11:46 PMresolved
May 22, 11:46 PM
resolved — This incident is now resolved.
May 22, 09:24 PM
monitoring — A fix has been implemented and we are currently monitoring the results.
May 22, 05:33 PM
identified — The cause of this issue has been identified and a fix is being implemented.
+1 more updates
Worker Pages Post-Deployment Errors
minorMay 22, 07:10 PM→May 22, 08:55 PMresolved
May 22, 08:55 PM
resolved — This incident has been resolved. Customers experiencing 5xx errors with Pages deployments should redeploy to resolve.
May 22, 08:49 PM
monitoring — A fix has been released customer experiencing 5xx errors on their pages deployments should redeploy to resolve.
May 22, 07:58 PM
identified — Issue has been identified, a fix is being implemented.
+1 more updates
Cloudflare Dashboard and Cloudflare API service issues
minorMay 22, 03:36 PM→May 22, 04:33 PMresolved
May 22, 04:33 PM
resolved — Impacted APIs and the Cloudflare dashboard have fully recovered.
May 22, 04:22 PM
monitoring — We have rolled back the affected service and are seeing impacted APIs and our dashboard begin to recover.
We expect recovery to be gradual as in-memory caches (not our CDN caches) associated with this...
May 22, 04:19 PM
monitoring — We are working to safely roll back the affected service underpinning our API entitlements system. We expect recovery to be gradual as in-memory caches (not our CDN caches) associated with this service...
+4 more updates
Cloudflare One DNS issues with .internal zones
minorMay 22, 07:52 AM→May 22, 08:06 AMresolved
May 22, 08:06 AM
resolved — This incident has been resolved.
May 22, 08:02 AM
monitoring — A fix has been implemented and we are monitoring the results.
May 22, 07:52 AM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Related Incident Histories
Get Cloudflare Outage Alerts
Be the first to know when Cloudflare go down.