Supabase Outage History
Past incidents and downtime events
Complete history of Supabase outages, incidents, and service disruptions. Showing 25 most recent incidents.
October 2026(2 incidents)
Upgrade Issues
5 updates
We've rolled out a fix for this issue and re-enabled upgrades in the dashboard. We apologize for the inconvenience.
The fix has been implemented. Upgrade operation has been restored. We will monitor for stability.
A fix has been developed and we are going through the review and implementation process.
We have identified the issue with the upgrade. To prevent issues, we have suspended the ability to upgrade projects while we resolve this issue. The problem is limited to upgrades from earlier versions of PG17 to the most recent release. We are working on a fix.
We have observed failures in attempted upgrades to 17.11.0.003. We are investigating.
Increased errors on management api leading to project operation failures
4 updates
This issue has been resolved and our error rates have returned back to normal. During this incident users would have observed unauthorized/5xx failures across multiple operations on the project operations and dashboard functions. We have since rolled out a fix and all functionality is restored.
We have identified a rollout causing error increase on management api dependant services, which is causing project operation failures and FGA Authentication errors across multiple functions. We have implementing a fix and observing recovery. Our teams are continuing to monitor for full resolution.
We are continuing to investigate this issue.
We are investigating an increase in errors on project update flows including creation, pausing/unpausing and upgrading across multiple regions.
September 2026(18 incidents)
Intermittent latency in Eastern US
10 updates
A fix for this issue has been implemented and our data shows previous impacted users have recovered.
A fix for this issue has been implemented and our data shows recovery for users on projects that have previously been affected. We expect this situation to be resolved, but will keep monitoring for a while until fully resolving this incident.
While we have observed significant improvement in rates of high latency, we note that some users are still experiencing issues during peak Eastern US business hours. We continue to work with our networking partners to isolate and resolve any lingering sources of high latency. We recognize that this is a longstanding issue and appreciate the patience of affected customers. We will continue to share additional updates here as soon as they are available.
Our networking partners have implemented a mitigation to the latency issue at the problematic PoP in the Eastern US, and we have since observed significant improvement in rates of high latency across the region. We are continuing to work with those partners to isolate any additional root causes of latency and improve the reliability of our networking infrastructure across the region.
We are seeing signs of improvement and are continuing to work alongside our networking partners towards a resolution. We will provide another update as more information becomes available.
We're continuing to coordinate with our networking partners to deliver a permanent resolution. We will provide updates as soon as they're available.
We are working with our networking partners on a permanent fix. While we do not have an estimated resolution time, we will share updates here as they become available.
A mitigation for this issue was applied earlier today, but we do not have sufficient evidence to conclude that the mitigation resulted in improvement to this eastern US latency issue. We have tied the issue to a particular PoP, and we are continuing to work with our networking partners to bring this issue to a final resolution. We will provide another update within 4 hours, if not before. We appreciate your patience.
We are continuing our work to fix this latency issue, which has been observed to impact clients connecting to Supabase Projects from the eastern United States. These clients may include servers and serverless functions located in that geographical region, regardless of the region in which the Project is hosted.
We have identified an issue with increased latency for clients in the eastern US during spikes caused by bursty traffic. This is most noticeable during EDT working hours around the :00 and :30 hour marks. We are actively working on a fix. We will provide updates as the fix is implemented.
Log Ingestion Degradation
4 updates
Log ingestion is normal.
Log ingestion has recovered. We are monitoring for continued stability.
The log ingestion issue was the result of a scaling gap. The relevant resources have been scaled and ingestion is recovering.
Log ingestion is experiencing some delays. Ingestion will be retried by clients.
Project Lifecycle Issues in eu-west-1
7 updates
This incident has been resolved.
We are continuing to monitor to ensure ongoing stability.
The remaining projects have now been brought back up, and we have no projects remaining on the unhealthy underlying hardware in the upstream infrastructure. We are monitoring to ensure ongoing stability.
Most projects have been brought back up, and the team is working on the remaining projects, which should be completed soon. This issue was related to specific underlying hardware in the region, so this was isolated to only projects on that hardware. Project lifecycle operations (restarts, upgrades, etc) broadly across the region remain available.
All projects affected by the upstream infrastructure issues, and mitigation efforts are underway internally. These affected projects will be brought back up on new hardware as quickly as possible.
We have isolated the scope of the problem to a specific upstream incident. We are working to address the upstream incident and determine mitigations.
We are investigating project lifecycle operation issues in eu-west-1.
Permission errors in the Supabase Dashboard
4 updates
This incident has been resolved. Administrative operations in the Supabase Dashboard are completing as expected, and we have observed no further permission related errors following the fix.
We have applied a fix, and administrative operations in the Supabase Dashboard are now completing as expected. We are monitoring the results to ensure the issue is fully resolved.
We have identified the issue causing some users to encounter permission-related errors, such as “You need additional permissions,” when performing administrative actions in the Supabase Dashboard. We are working on a fix and will provide another update once it has been implemented.
We are investigating reports of users encountering permission-related errors, such as “You need additional permissions,” when performing administrative actions in the Supabase Dashboard. This may prevent some users from managing their projects through the Dashboard. We are working to identify the cause and will provide further updates as they become available.
Storage search failing for restored projects
3 updates
Storage is now operating normally. We apologise for the disruption. Hardening measures are being put in place to prevent recurrence and will be communicated upon completion.
A fix has been implemented for the affected tenants and we are monitoring the results. We will continue to monitor the situation and will provide further updates as more information becomes available.
We have identified an issue with Storage for projects are restoring from backups. Users may experience increased 500 errors. We are working to identify the root cause and will notify for any progress as soon as we have an update
Supabase CLI CI workflow failures
4 updates
This incident has been resolved.
We are no longer seeing rate limiting issues affecting Supabase CLI CI workflows. We're continuing to monitor the service for stability while we roll out a fallback patch to improve resilience and help prevent the issue from recurring.
We've identified the cause and are working on a fix.
We're seeing rate limiting issues causing Supabase CLI CI workflow failures
Increased error rate in project creation and project restore
4 updates
This incident has been resolved.
A fix has been implemented and we are monitoring the results.
We've identified the issue affecting project creation and are implementing a fix. Users may experience delays when creating new projects while we work to resolve this.
We are currently investigating this issue
Supavisor connection disruptions in EU West 1 (Ireland)
3 updates
This incident has been resolved. Following the restart of the affected Supavisor node, error rates returned to normal and no further disruptions have been observed during the monitoring period. All services are operating normally.
The affected Supavisor node has been restarted, and error rates have returned to normal levels. We’ll continue to monitor the service to ensure stability.
Some projects in the EU West 1 (Ireland) region may experience disruptions to Supavisor connections. Our team is aware of the issue and actively working on a resolution. We’ll share further updates as they become available.
Project creations are degraded in multiple regions
2 updates
The latency has recovered and the incident is now resolved.
We have identified increased latency in Project creations in these regions from 0730 UTC to 0805 UTC: ap-northeast-1 ap-northeast-2 eu-central-1 eu-central-2 eu-north-1 eu-west-1 eu-west-3 us-west-1 The latency has since recovered and our teams are monitoring for full recovery. Existing project availability has not been impacted.
Project Lifecycle Activity Degradation
4 updates
Project lifecycle operations are behaving normally.
Project lifecycle operations have remained stable. We will continue to monitor the platform.
We are observing recovery in project lifecycle operations. Our team is investigating the root cause and actively working to prevent recurrence.
We are experiencing degradation of project lifecycle activities. We are investigating.
Query slowness for projects running Postgres version 14 in us-east-1 and ap-northeast-2
5 updates
This incident has been resolved.
The fix has been rolled out to us-east-1. We will continue to monitor both regions for stability.
The fix has been implemented for ap-northeast-2 and we're working on implementing the fix for us-east-1. We will continue to provide updates as progress is made.
We are continuing to work on a fix and will provide updates as things progress.
Projects running Postgres version 14 in us-east-1 and ap-northeast-2 may experience query slowness. We've identified the cause and are working on a fix.
Edge Function Latency
3 updates
This incident has been resolved.
Error rates have returned to normal, and the service is operating as expected. The team continues to investigate the underlying cause of the latency and spike in 503 errors.
We are investigating reports of increased Edge Function latency and elevated rates of HTTP 503 responses, beginning at approximately 06:00 UTC. Our team is working to identify the cause and will provide further updates as they become available.
Auth Service Outage
4 updates
This incident has been resolved.
We implemented a fix and are monitoring the system.
We have identified a subset of projects with a failing Auth service. Our team is working to remediate the issue.
We have identified an issue related to the Auth service on some projects. We are actively working on a fix.
Unresponsive Projects
8 updates
This incident has been resolved.
We have rolled out a fix across all regions and are continuing to monitor over the next few hours. Due to this incident, impacted users who's project were compute constrained would have received a 'Your Supabase Project is running out of Disk IO Budget' email which is no longer valid. No further action is required and your project availability should be restored to normal.
We have rolled out a fix across all regions and are continuing to monitor over the next few hours. Users still affected by project outages are encouraged to restart their projects which has shown to resolve lasting errors.
We have rolled out a version of the fix across all regions that will prevent recurrence of the issue. Users still affected by project outages are encouraged to restart their projects.
Fix rollouts have been successful in the initial regions, we are proceeding to roll out the fix globally.
A refined fix is being rolled out to specific regions, we are assessing the impact of the fix.
We have identified why projects are becoming unresponsive and are implementing a mitigation.
We are aware of Nano projects becoming unresponsive after a period of time, typically hours. We are investigating.
Latency issues resulting in 504 errors
1 update
We observed latency issues over the weekend resulting in 504 errors primarily impacting customers on the Free tier. The incident has been resolved.
Brief connection disruptions in us-east-1 (N. Virginia)
1 update
Between 05:50–06:05 UTC some customer using Supavisor in us-east-1 may have experienced brief dropped connections or connection disruptions. This issue was caused by an unexpected restart of Supavisor instances in the affected cluster. We apologize for any disruption caused.
Project Lifecycle Actions Showing increased error rates across all regions
9 updates
Lifecycle operations have been re-enabled for 100% of users and error rates have returned to normal.
Lifecycle operations have been re-enabled for 100% of users and error rates have returned to normal. We are going to monitor to ensure that things stay stable. The team is working through any remaining projects which did not automatically resolve. Some users may also notice that backups will happen a bit later than usual, but these jobs are running and completing normally.
We've increased project lifecycle operations to 50% of users and things are holding steady. We're continuing to ramp this up until operations are restored for all users. This is impacting all project-related lifecycle operations: Creates, Configuration changes, Restarts, Compute size Updates, etc. Running projects remain running, and the data APIs and direct postgres client connections are NOT affected.
Error rates have returned to normal, and the backlogs are draining well. We are beginning to slowly re-enable lifecycle operations for users. We will be monitoring impact, and we hope to have this re-enabled everywhere soon. We will leave this in this state until lifecycle operations have been completely restored. Running projects remain running, and the data APIs and direct postgres client connections are NOT affected.
We are seeing incremental improvements internally. There is a large backlog of actions that we are working through, but things are progressing. Once we make it through most of the backlog, we will re-enable lifecycle actions. This is impacting all project-related lifecycle operations: Creates, Configuration changes, Restarts, Compute size Updates, etc. Running projects remain running, and the data APIs and direct postgres client connections are NOT affected.
The team is continuing to work on restoring project lifecycle operations. Out of caution, we have disabled lifecycle operations. This is impacting all project-related lifecycle operations: Creates, Configuration changes, Restarts, Compute size Updates, etc. Running projects remain running, and the data APIs and direct postgres client connections are NOT affected. We will provide additional updates as we have more information.
The team has applied a fix, but error rates remain high. We are continuing to work and will take other necessary steps to resolve this as soon as possible. Running projects remain running, and the data APIs and direct postgres client connections are NOT affected. Out of an abundance of caution, we would suggest against taking any of these actions until this incident is resolved: Creates, Configuration changes, Restarts, or Compute size changes. We will provide additional updates as we have more information.
We have identified the source of the errors with project lifecycle actions, and the team is currently working to resolve it. This is impacting all project-related lifecycle operations: Creates, Configuration changes, Restarts, Compute size Updates, etc. Running projects remain running, and the data APIs and direct postgres client connections are NOT affected. Out of an abundance of caution, we would suggest against taking any of these actions until this incident is resolved. We will provide additional updates as we have more information.
We are seeing increased error rates in actions across all project lifecycle actions - Creations, Deletions, Restores, Configuration and Compute size upgrades. We are currently looking into the cause. Out of an abundance of caution, we would suggest against taking any of these actions until this incident is resolved. We will provide additional updates as we have more information
User unable to log in to Supabase Dashboard
4 updates
This incident has been resolved. Users should now be able to log in to the Supabase Dashboard normally. Projects and non-Dashboard traffic were unaffected throughout the incident.
A recent change affected users ability to log in to the Supabase Dashboard. We’ve reverted the change, and testing indicates that the issue is resolved. Please try logging in again. If you’re still unable to log in, perform a full browser refresh and retry. Projects and non-Dashboard traffic remained unaffected.
We’re investigating an issue preventing users from logging in to the Supabase Dashboard. Users who were logged into the dashboard were logged out. Dashboard actions are currently not available. Projects remain online and available. Non-Dashboard traffic is not impacted. We’ll share another update as soon as we have more information.
We are currently investigating an issue where users are unable to login to the Supabase dashboard
August 2026(5 incidents)
Project Creation Failures
7 updates
Project creation has returned to baseline consistently.
Project creation is reporting as recovered across the platform. We will monitor for stability in the near term.
We are seeing the mitigation steps having the desired effect. Project creation is recovering.
While the first set of actions are taking effect, we are implementing a second set of likely mitigations to attempt to facilitate improvement in project creation.
We continue to work this issue. The steps we have taken are addressing the hypothesized cause of the issue. We are implementing further related mitigations.
We have a working hypothesis on the cause of the issue, and are implementing steps to try to improve project creation performance.
Project creation is failing for new projects on the platform. We are investigating.
Increased response times for requests
11 updates
Response times have recovered in all regions. This issue is now resolved.
Response times have recovered in all regions. We will continue to monitor throughout the weekend.
The rollout has been completed in all regions. We will continue to monitor.
The roll out has also been completed for us-east-1.
PostgREST 14.5 has been deployed since 12:00pm UTC to all AP regions: ap-east-1, ap-northeast-1, ap-northeast-2, ap-south-1, ap-southeast-1, and ap-southeast-2 as well as sa-east-1 and ca-central-1, eu-central-1, eu-central-2, eu-north-1, eu-west-2, and eu-west-3, us-west-1 We'll continue to provide updates as we roll out the change for the remaining impacted regions.
We are continuing to work through the remediation plan for the latency issues. We will provide a further update as soon as more information is available.
The team has identified the change which resulted in additional latency and error rates for some data API Requests. They are preparing to roll this change back. This rollout will take some time, and we will update again as there is news on the progress of the fix.
We are continuing to investigate this issue and we’ll share more information as soon as it becomes available.
We are continuing to investigate this issue and we’ll share more information as soon as it becomes available.
We’re continuing to investigate the issue causing increased response times for requests and 525 errors. Our team remains actively engaged in the investigation, we’ll provide another update as soon as we have more details.
We’re currently investigating latency issue that may cause increased response times for a small percentage of requests. In some cases, this may also result in 525 errors. Our team is actively working to resolve the issue. We’ll share another update as soon as we have more information.
Projects failing to load Supautils in multiple regions
1 update
PostgreSQL 15 projects were failing to load /usr/lib/postgresql/15/lib/supautils.so because GLIBC_2.33 is unavailable on affected hosts. This disrupted database access in multiple regions. Rollback is now complete and we are seeing access restored to projects in the affected regions.
pgBouncer issues on some older projects
7 updates
The fix has remained stable across all regions, and the issue has been resolved.
A fix has been rolled out across all regions, and results are positive. We will continue monitoring to ensure the service remains stable. Moving this incident to monitoring.
An enhanced automated solution is currently being tested in staging. It is expected to be more effective and efficient than the approach used previously. Once testing has completed successfully, we will use this approach to roll out the fix in production. We will provide further updates as this work progresses.
We are continuing to rollout the fix to further regions.
This issue is fixed in eu-central-2 and ap-south-1. We are continuing to rollout the fix to all regions.
Some users on Project versions 15.1 and older are experiencing a pgBouncer configuration issue causing connection issues for the Dedicated Pooler and Storage services. We are continuing our investigation of this issue.
Some users on older Projects are experiencing a pgBouncer configuration issue causing connection issues for the Dedicated Pooler and Storage services. This issue should only affect users with Project versions 15.1 and older. We have determined the cause of this issue and we are rolling out a fix.
Increased rates of Pooler connection timeouts in us-east-1
3 updates
This incident has been resolved.
We have identified a degraded Supavisor node and we have rolled out a fix. We are monitoring to ensure continued stability. Confirmed Impact: On Aug 24, 2026 between 14:30 and 15:20 UTC we observed increased rates of connection timeouts connecting to Supavisor in us-east-1 due to a degraded node.
We are aware of reports of increased rates of connection timeouts for users connecting to Projects in us-east-1 via Supavisor.
📡 Tired of checking Supabase status manually?
Better Stack monitors uptime every 30 seconds and alerts you instantly when Supabase goes down.