Dropbox API Outage History
50 incidents reported. Data sourced from the official Dropbox API status page.
50
Total Incidents
5
Major/Critical
37
Minor
50
Resolved
September 2026
Some customers are unable to access certain website routes and features.
majorSep 9, 09:36 PM→Sep 9, 10:35 PMresolved
Sep 9, 10:35 PM
resolved — This incident has been resolved.
Sep 9, 09:36 PM
investigating — a number of pages and features are not working for some customers. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Customer support via telephone may be unavailable for some users
minorSep 3, 10:13 PM→Sep 4, 05:02 AMresolved
Sep 4, 05:02 AM
resolved — This incident has been resolved.
Sep 3, 10:13 PM
investigating — We're currently experiencing issues with phone services due to a wider AWS outage. We are investigating and will share another update shortly.
August 2026
Some Dropbox Protect features are not working correctly
minorAug 25, 11:14 PM→Aug 26, 11:01 AMresolved
Aug 26, 11:01 AM
resolved — This incident has been resolved.
Aug 25, 11:14 PM
investigating — We are currently experiencing issues with the Items and Reports areas in Dropbox Protect, resulting in intermittent failures for some users. We are working to resolve the issue as quickly as possible....
Dropbox is not working as expected for some users
minorAug 21, 01:18 PM→Aug 21, 03:12 PMresolved
Aug 21, 03:12 PM
resolved — This incident has been resolved.
Aug 21, 02:26 PM
monitoring — A fix has been implemented and we are monitoring the results.
Aug 21, 02:15 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
July 2026
Dropbox is not working as expected for some users
minorJul 23, 03:12 PM→Jul 23, 03:36 PMresolved
Jul 23, 03:36 PM
resolved — This incident has been resolved.
Jul 23, 03:32 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jul 23, 03:12 PM
investigating — Dropbox is not working as expected for some users. We’re working to fix the problem as quickly as we can.
June 2026
Shared content downloads are degraded
minorJun 8, 07:43 PM→Jun 12, 04:54 PMresolved
Jun 12, 04:54 PM
resolved — Shared content downloads on Dropbox is back up and running! Thanks for bearing with us.
Jun 8, 07:43 PM
investigating — We are currently experiencing performance issues affecting shared content downloads on Dropbox. Some people may see significantly slower downloads than expected, including delays when downloading smal...
May 2026
Opening a video or audio file might not be working for users
minorMay 27, 08:05 PM→May 27, 10:31 PMresolved
May 27, 10:31 PM
resolved — This incident has been resolved.
May 27, 09:56 PM
monitoring — A fix has been implemented and we are monitoring the results.
May 27, 08:05 PM
investigating — Opening a video or audio file might not be working for users
Availability was impacted across a number of services
noneMay 18, 05:00 PM→May 18, 05:00 PMresolved
May 18, 07:11 PM
resolved — A number of services across Dropbox experienced slower than expected load times between 17:01:50 and 17:42:50 UTC.
This included the ability to add members to teams and share content.
April 2026
Dropbox may be unavailable for some users
majorApr 15, 03:51 AM→Apr 15, 04:16 AMresolved
Apr 15, 04:16 AM
resolved — This incident has been resolved.
Apr 15, 03:55 AM
investigating — We are continuing to investigate this issue.
Apr 15, 03:51 AM
investigating — Dropbox may be unavailable for some users. We’re working to fix the problem as quickly as we can.
Dash Chat might not be working for some users
minorApr 9, 09:32 PM→Apr 10, 12:54 AMresolved
Apr 10, 12:54 AM
resolved — This incident has been resolved.
Apr 9, 09:52 PM
monitoring — A fix has been implemented and we are monitoring the results.
Apr 9, 09:32 PM
investigating — Dash Chat might not be working for some users. We're working to fix the problem as quickly as we can.
January 2026
Dropbox.com is not working for some users
minorJan 22, 01:30 AM→Jan 22, 10:00 AMresolved
Jan 22, 10:57 AM
resolved — This incident has been resolved.
Jan 22, 09:46 AM
investigating — Dropbox.com (Web) is not working for some users in Singapore and the Philippines. Mobile and Desktop are operational. We’re working to fix the problem as quickly as we can. We’ll share another update ...
We’re having some trouble with our payment page
minorJan 15, 06:59 AM→Jan 15, 08:19 AMresolved
Jan 15, 08:19 AM
resolved — This incident has been resolved.
Jan 15, 07:49 AM
monitoring — A fix has been implemented and we are monitoring the results.
Jan 15, 06:59 AM
investigating — We’re having some trouble with our payment page. We’re working to fix the problem as quickly as we can.
November 2025
DocSend impacted by ongoing Cloudflare outage
majorNov 18, 02:38 PM→Nov 18, 02:53 PMresolved
Nov 18, 02:53 PM
resolved — This incident has been resolved.
Nov 18, 02:38 PM
identified — We are aware that DocSend has been impacted by the ongoing Cloudflare outage
Dropbox Chat unavailable
majorNov 14, 08:00 PM→Nov 14, 09:11 PMresolved
Nov 14, 09:11 PM
resolved — This incident has been resolved.
Nov 14, 08:00 PM
investigating — Dropbox Chat is currently unavailable, we are investigating the issue.
October 2025
Google Drive and One Drive Dash connectors are not working for some users
minorOct 21, 02:32 PM→Oct 21, 09:13 PMresolved
Oct 21, 09:13 PM
resolved — This incident has been resolved.
Oct 21, 02:32 PM
investigating — The Google Drive and One Drive connectors in Dash are not working for some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Images not loading in Dropbox Paper
minorOct 14, 09:06 AM→Oct 14, 12:49 PMresolved
Oct 14, 12:49 PM
resolved — This incident has been resolved.
Oct 14, 09:06 AM
investigating — We are aware that Images and the preview of an images are not loading in Dropbox Paper.
September 2025
Dropbox is not working as expected for some users.
minorSep 23, 06:55 PM→Sep 23, 07:17 PMresolved
Sep 23, 07:17 PM
resolved — This incident has been resolved.
Sep 23, 07:10 PM
investigating — We are continuing to investigate this issue.
Sep 23, 06:55 PM
investigating — We’re having some trouble with our services currently. We’re working to fix the problem as quickly as we can.
Dropbox.com is not working for some users
minorSep 2, 01:16 PM→Sep 2, 01:48 PMresolved
Sep 2, 01:48 PM
resolved — This incident has been resolved.
Sep 2, 01:16 PM
investigating — Dropbox.com is not working for some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
August 2025
Pop up to sign in On Microsoft Office Files
minorAug 29, 07:17 PM→Aug 30, 10:01 AMresolved
Aug 30, 10:01 AM
resolved — This incident has been resolved.
Aug 29, 07:17 PM
investigating — We are working with Microsoft to investigate this issue. Please close the pop up until fix a is implemented.
May 2025
Intermittent Loading Issues on Dropbox Website
minorMay 23, 07:31 PM→May 23, 08:24 PMresolved
May 23, 08:24 PM
resolved — This incident has been resolved.
May 23, 07:31 PM
identified — Some users may experience longer than usual load times on the Dropbox website. We are actively investigating and working to resolve the issue.
The Dash Confluence connector may be unavailable for some users.
minorMay 15, 04:35 PM→May 16, 07:15 PMresolved
May 16, 07:15 PM
resolved — This incident has been resolved.
May 15, 04:35 PM
investigating — We are currently investigating this issue.
Dropbox may be unavailable for some users.
minorMay 14, 06:24 PM→May 14, 07:24 PMresolved
May 14, 07:24 PM
resolved — This incident has been resolved.
May 14, 06:49 PM
monitoring — A fix has been implemented and we are monitoring the results.
May 14, 06:33 PM
investigating — We are continuing to investigate this issue.
+1 more updates
Dash Search might not be working for some users.
minorMay 5, 09:38 PM→May 6, 03:40 AMresolved
May 6, 03:40 AM
resolved — This incident has been resolved.
May 5, 09:38 PM
investigating — Dash Search might not be working for some users. We are working to fix the problem as quickly as we can.
Dash Chat might not be working for some users
minorMay 5, 06:26 PM→May 5, 09:30 PMresolved
May 5, 09:30 PM
resolved — This incident has been resolved.
May 5, 06:26 PM
investigating — Dash Chat might not be working for some users. We're working to fix the problem as quickly as we can.
Dropbox may be unavailable for some users
minorMay 1, 09:57 PM→May 2, 02:07 AMresolved
May 2, 02:07 AM
resolved — This incident has been resolved.
May 2, 01:29 AM
identified — The issue has been identified and a fix is being implemented.
May 1, 10:38 PM
investigating — We are continuing to investigate this issue.
+1 more updates
April 2025
Dropbox was not working as expected for some users
noneApr 17, 05:21 PM→Apr 17, 05:21 PMresolved
Apr 17, 05:21 PM
resolved — Retroactive update - Dropbox was not working as expected for some users. We quickly identified and fixed the problem.
Issue downloading single files on safari 18.4
noneApr 9, 07:58 PM→Apr 10, 07:53 AMresolved
Apr 10, 07:53 AM
resolved — This incident has been resolved.
Apr 9, 07:58 PM
identified — We are aware some people are experiencing an issue downloading single files on safari 18.4. We are working to resolve this.
March 2025
Some Windows users may not be able to use the online-only functionality
minorMar 20, 08:35 PM→Apr 4, 04:22 PMresolved
Apr 4, 04:22 PM
resolved — This incident has been resolved.
Apr 1, 03:14 PM
identified — We are continuing to work on a fix for this issue.
Mar 26, 04:32 PM
identified — We are continuing to work on a fix for this issue.
+2 more updates
January 2025
DocSend unavailable
majorJan 22, 03:45 PM→Jan 22, 03:52 PMresolved
Jan 22, 03:52 PM
resolved — Issue is resolved. Customers could have experienced errors or long load times from 14:21 to 14:24 UTC and 15:32 to 15:31 UTC
Jan 22, 03:45 PM
investigating — DocSend is currently unavailable, we are investigating the issue.
December 2024
Dash Answers was down for some users
noneDec 12, 12:36 AM→Dec 12, 12:36 AMresolved
Dec 12, 12:36 AM
resolved — Retroactive update - Dash Answers was unavailable for some users beginning around 11:30pm UTC on December 11th. This was due to an OpenAI outage. We are back up and running!
November 2024
Desktop installer failing to download
minorNov 7, 11:31 PM→Nov 12, 11:08 PMresolved
Nov 12, 11:08 PM
resolved — This incident has been resolved.
Nov 7, 11:31 PM
investigating — We are aware of reports regarding the desktop application meta-installer failing to download for some Windows users. Our team is currently investigating the issue.
Dropbox.com was down
noneNov 12, 11:05 PM→Nov 12, 11:05 PMresolved
Nov 12, 11:05 PM
resolved — Retroactive update - Dropbox.com was down for some users. We quickly identified and fixed the problem, so we're back up and running!
October 2024
Dropbox may not be working as expected
minorOct 23, 06:24 PM→Oct 23, 06:59 PMresolved
Oct 23, 06:59 PM
resolved — We’re back! Dropbox should be up and running. Thanks for bearing with us.
Oct 23, 06:36 PM
monitoring — A fix has been implemented and we are monitoring the results.
Oct 23, 06:24 PM
investigating — We are continuing to investigate this issue.
+1 more updates
September 2024
Creating and opening a File Request might not be working for some users
minorSep 26, 09:37 PM→Sep 27, 12:48 AMresolved
Sep 27, 12:48 AM
resolved — This incident has been resolved.
Sep 26, 09:37 PM
investigating — Creating and opening a File Request might not be working for some users. We are currently investigating this issue.
The Desktop App might not be loading for some users
minorSep 25, 06:10 PM→Sep 26, 12:01 AMresolved
Sep 26, 12:01 AM
resolved — This incident has been resolved.
Sep 25, 06:10 PM
investigating — The Desktop App might not be loading for some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Dropbox may not be working as expected for some users
noneSep 3, 06:26 PM→Sep 3, 07:20 PMresolved
Sep 3, 07:20 PM
resolved — This incident has been resolved.
Sep 3, 06:26 PM
investigating — Users may be experiencing issues with uploading or previewing certain files across Dropbox. We are working to resolve the issue as quickly as possible. Thank you for your patience.
July 2024
Desktop app installer may not be working as expected
minorJul 9, 08:54 PM→Jul 9, 09:18 PMresolved
Jul 9, 09:18 PM
resolved — This incident has been resolved.
Jul 9, 08:54 PM
investigating — The desktop app installer may not be working as expected for some users. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Dropbox.com may not be working as expected
minorJul 8, 09:43 PM→Jul 8, 09:57 PMresolved
Jul 8, 09:57 PM
resolved — This incident has been resolved.
Jul 8, 09:43 PM
investigating — The Dropbox website may not be working as expected for some users. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
June 2024
Photos tab in Android app may not be loading as expected
minorJun 21, 06:30 PM→Jun 25, 04:33 PMresolved
Jun 25, 04:33 PM
resolved — This incident has been resolved.
Jun 21, 09:54 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 21, 06:30 PM
investigating — The photos tab in Dropbox's Android app may not be loading as expected for some users. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Phone support may not be working as expected for some Team Admins
minorJun 22, 01:47 AM→Jun 22, 05:46 AMresolved
Jun 22, 05:46 AM
resolved — This incident has been resolved.
Jun 22, 01:47 AM
investigating — Calling support may not be working as expected for some Team Admins. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Enterprise console may not be working as expected
minorJun 18, 02:07 PM→Jun 18, 04:18 PMresolved
Jun 18, 04:18 PM
resolved — This incident has been resolved.
Jun 18, 04:03 PM
identified — The issue has been identified and a fix is being implemented.
Jun 18, 02:07 PM
investigating — Enterprise console may not be working as expected for some users. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
May 2024
Degraded experience on mobile Android users
minorMay 24, 12:41 AM→Jun 7, 07:40 PMresolved
Jun 7, 07:40 PM
resolved — This incident has been resolved. Users are advised to download the latest version of the mobile application.
May 28, 05:25 PM
identified — We are continuing to work on a fix for this issue.
May 24, 08:21 PM
identified — Some users may continue to have a degraded experience on mobile Android. The issue has been identified and a fix will be implemented.
+1 more updates
Dropbox is not working as expected for some users
minorMay 30, 06:43 PM→May 30, 08:15 PMresolved
May 30, 08:15 PM
resolved — This incident has been resolved.
May 30, 07:26 PM
monitoring — A fix has been implemented and we are monitoring the results.
May 30, 06:43 PM
investigating — We’re having some trouble with our services currently. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Viewing shared links might not be working for some users
minorMay 29, 03:57 PM→May 29, 04:24 PMresolved
May 29, 04:24 PM
resolved — This incident has been resolved.
May 29, 04:10 PM
monitoring — A fix has been implemented and we are monitoring the results.
May 29, 03:57 PM
investigating — Viewing shared links might not be working for some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Dropbox is not working as expected for some users
minorMay 28, 03:46 PM→May 28, 05:14 PMresolved
May 28, 05:14 PM
resolved — This incident has been resolved.
May 28, 04:20 PM
monitoring — A fix has been implemented and we are monitoring the results.
May 28, 03:46 PM
investigating — We’re having some trouble with our services currently. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Brief intermittent availability issues
minorMay 23, 10:43 AM→May 23, 11:32 AMresolved
May 23, 11:32 AM
resolved — This incident has been resolved.
May 23, 10:43 AM
investigating — We are currently investigating brief availability issues that may affect logging in and other aspects of our product.
Dropbox is not working for some users
minorMay 17, 04:38 PM→May 17, 07:08 PMresolved
May 17, 07:08 PM
resolved — This incident has been resolved.
May 17, 04:38 PM
investigating — Dropbox is not working for some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Single Sign-On (SSO) may not be working as expected
noneMay 14, 12:19 AM→May 14, 12:19 AMresolved
May 14, 12:19 AM
resolved — This incident has been resolved.
Single Sign-On (SSO) may not be working as expected
noneMay 13, 03:31 PM→May 14, 12:14 AMresolved
May 14, 12:14 AM
resolved — SSO is back up and running! Thanks for bearing with us.
May 13, 05:17 PM
identified — The issue has been identified and a fix is being implemented.
May 13, 03:31 PM
investigating — Single Sign-On (SSO) may not be working as expected for some users. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
April 2024
Audit logs may not be working as expected
minorApr 29, 03:30 AM→Apr 29, 04:35 AMresolved
Apr 29, 04:35 AM
resolved — This incident has been resolved.
Apr 29, 03:30 AM
investigating — Audit logs may not be working as expected for some team admins. We are working to fix the problem as quickly as we can. We’ll share another update shortly.
Related Incident Histories
Get Dropbox API Outage Alerts
Be the first to know when Dropbox API go down.