npm Registry Outage History
50 incidents reported. Data sourced from the official npm Registry status page.
50
Total Incidents
10
Major/Critical
37
Minor
50
Resolved
September 2026
Package Publish Degradation
minorSep 15, 05:20 PM→Sep 15, 06:19 PMresolved
Sep 15, 06:19 PM
resolved — This incident has been resolved.
Sep 15, 06:18 PM
identified — Stable
Sep 15, 05:20 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Publishing Packages Degraded Performance
minorSep 15, 04:13 PM→Sep 15, 04:35 PMresolved
Sep 15, 04:35 PM
resolved — This incident has been resolved.
Sep 15, 04:13 PM
investigating — We are investigating delays affecting npm package publishing. Some newly published package versions may take longer than expected to become available.
npm audits endpoint is having issues
minorSep 4, 11:29 AM→Sep 4, 01:48 PMresolved
Sep 4, 01:48 PM
resolved — This incident has been resolved.
Sep 4, 01:27 PM
monitoring — A fix has been implemented and we are monitoring the results.
Sep 4, 11:29 AM
investigating — We are currently investigating this issue.
Intermittent Failures Impacting npm Publish
minorSep 3, 09:42 PM→Sep 3, 11:21 PMresolved
Sep 3, 11:21 PM
resolved — This incident has been resolved.
Sep 3, 10:41 PM
monitoring — A fix has been implemented and we are monitoring the results.
Sep 3, 10:17 PM
investigating — We are continuing to investigate this issue.
+1 more updates
July 2026
intermittent Publish Failures
minorJul 30, 12:06 PM→Jul 30, 04:30 PMresolved
Jul 30, 04:30 PM
resolved — This incident has been resolved.
Jul 30, 03:21 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jul 30, 12:06 PM
investigating — We are currently investigating this issue.
Publish and Install failures
majorJul 24, 11:08 AM→Jul 24, 11:38 AMresolved
Jul 24, 11:38 AM
resolved — This incident has been resolved.
Jul 24, 11:36 AM
monitoring — A fix has been implemented and we are monitoring the results.
Jul 24, 11:32 AM
investigating — We are continuing to investigate this issue.
+1 more updates
intermittent Publish and Install Failures
minorJul 23, 04:09 PM→Jul 23, 07:52 PMresolved
Jul 23, 07:52 PM
resolved — This incident has been resolved.
Jul 23, 06:04 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jul 23, 04:09 PM
investigating — We are currently investigating this issue.
June 2026
intermittent Publish Failures
minorJun 12, 12:08 PM→Jun 12, 12:57 PMresolved
Jun 12, 12:57 PM
resolved — This incident has been resolved.
Jun 12, 12:44 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 12, 12:33 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
April 2026
npm website issues
minorApr 29, 08:07 PM→Apr 29, 08:49 PMresolved
Apr 29, 08:49 PM
resolved — This incident has been resolved.
Apr 29, 08:49 PM
investigating — We are continuing to investigate this issue.
Apr 29, 08:07 PM
investigating — We are currently investigating this issue.
Degraded Performance in View Package and Login on npmjs.com
minorApr 29, 04:48 PM→Apr 29, 07:35 PMresolved
Apr 29, 07:35 PM
resolved — This incident has been resolved.
Apr 29, 06:47 PM
monitoring — A fix has been implemented and we are monitoring the results.
Apr 29, 04:48 PM
investigating — We are currently investigating this issue.
npm website degraded service
minorApr 28, 07:55 PM→Apr 28, 10:24 PMresolved
Apr 28, 10:24 PM
resolved — This incident has been resolved.
Apr 28, 09:04 PM
monitoring — A fix has been implemented and we are monitoring the results.
Apr 28, 07:55 PM
investigating — We are currently investigating this issue.
npm Website is unavailable
criticalApr 27, 09:06 PM→Apr 27, 10:30 PMresolved
Apr 27, 10:30 PM
resolved — This incident has been resolved.
Apr 27, 10:28 PM
investigating — We are continuing to investigate this issue.
Apr 27, 09:06 PM
investigating — We are currently investigating this issue.
Increased errors in viewing packages and authentication on npmjs.com
noneApr 1, 10:05 AM→Apr 1, 01:12 PMresolved
Apr 1, 01:12 PM
resolved — This incident has been resolved.
Apr 1, 12:20 PM
monitoring — A fix has been implemented and we are monitoring the results.
Apr 1, 10:05 AM
investigating — We are observing increased errors in viewing packages and authentication on npmjs website. We are investigating this issue.
March 2026
Degraded Performance in View Package and Login on npmjs.com
minorMar 31, 07:12 PM→Mar 31, 09:49 PMresolved
Mar 31, 09:49 PM
resolved — This incident has been resolved.
Mar 31, 09:12 PM
monitoring — A fix has been implemented and we are monitoring the results.
Mar 31, 08:42 PM
investigating — We have implemented initial fixes and are continuing to investigate this issue
+1 more updates
delay and errors viewing packages and submitting web based authentication
minorMar 30, 04:41 PM→Mar 30, 07:17 PMresolved
Mar 30, 07:17 PM
resolved — This incident has been resolved.
Mar 30, 06:19 PM
monitoring — A fix has been implemented and we are monitoring the results.
Mar 30, 05:56 PM
investigating — We have implemented some initial fixes. We are continuing to investigate the issue.
+1 more updates
delay and errors viewing packages and submitting web based authentication
minorMar 30, 02:54 PM→Mar 30, 03:59 PMresolved
Mar 30, 03:59 PM
resolved — This incident has been resolved.
Mar 30, 03:30 PM
monitoring — A fix has been implemented and we are monitoring the results.
Mar 30, 03:17 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Issue with npm website and login.
majorMar 25, 10:39 PM→Mar 25, 11:26 PMresolved
Mar 25, 11:26 PM
resolved — This incident has been resolved.
Mar 25, 11:10 PM
monitoring — A fix has been implemented and we are monitoring the results.
Mar 25, 10:39 PM
investigating — We are currently investigating this issue.
Degraded performance for package publish
minorMar 5, 11:41 AM→Mar 5, 05:35 PMresolved
Mar 5, 05:35 PM
resolved — This incident has been resolved.
Mar 5, 01:01 PM
monitoring — A fix has been implemented and we are monitoring the results.
Mar 5, 11:41 AM
investigating — We are currently investigating this issue.
February 2026
Degraded performance with package installation
minorFeb 25, 06:43 PM→Feb 25, 08:03 PMresolved
Feb 25, 08:03 PM
resolved — This incident has been resolved.
Feb 25, 07:28 PM
monitoring — A fix has been implemented and we are monitoring the results.
Feb 25, 07:24 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
npm publishing impacted
minorFeb 17, 08:01 PM→Feb 17, 10:28 PMresolved
Feb 17, 10:28 PM
resolved — This incident has been resolved.
Feb 17, 09:17 PM
monitoring — A fix has been implemented and we are monitoring the results.
Feb 17, 08:01 PM
investigating — We are currently investigating this issue.
January 2026
Degraded Experience Installing and Viewing Packages
minorJan 29, 08:04 PM→Jan 29, 08:49 PMresolved
Jan 29, 08:49 PM
resolved — This incident has been resolved.
Jan 29, 08:18 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jan 29, 08:04 PM
investigating — We are currently investigating this issue.
December 2025
Issue connecting to website and registry
majorDec 5, 09:02 AM→Dec 5, 09:42 AMresolved
Dec 5, 09:42 AM
resolved — This incident has been resolved.
Dec 5, 09:17 AM
monitoring — A fix has been implemented and we are monitoring the results.
Dec 5, 09:02 AM
investigating — We are currently investigating this issue.
November 2025
npmjs.com - Service Disruption
noneNov 18, 01:34 PM→Nov 18, 07:11 PMresolved
Nov 18, 07:11 PM
resolved — We have confirmed that all systems are now fully operational and the connectivity issues have been completely resolved.
Nov 18, 07:09 PM
monitoring — This incident has been resolved. All services are now operating normally. We apologize for the disruption and appreciate your patience.
Nov 18, 03:23 PM
monitoring — A fix has been implemented and we are monitoring the results.
+1 more updates
Issue with npm website and login
minorNov 6, 01:56 PM→Nov 6, 02:28 PMresolved
Nov 6, 02:28 PM
resolved — This incident has been resolved.
Nov 6, 02:08 PM
monitoring — A fix has been implemented and we are monitoring the results.
Nov 6, 01:58 PM
investigating — We are continuing to investigate this issue.
+1 more updates
October 2025
Issue with package publishing
minorOct 20, 05:20 PM→Oct 20, 08:15 PMresolved
Oct 20, 08:15 PM
resolved — This incident has been resolved.
Oct 20, 07:20 PM
monitoring — We are seeing recovery in package publishing. We will continue to monitor the results.
Oct 20, 05:20 PM
investigating — We are currently investigating this issue.
Degraded performance of package publish and install
minorOct 20, 09:31 AM→Oct 20, 01:32 PMresolved
Oct 20, 01:32 PM
resolved — This incident has been resolved.
Oct 20, 10:50 AM
monitoring — A fix has been implemented and we are monitoring the results.
Oct 20, 09:31 AM
investigating — We are currently investigating this issue.
Degraded performance on npmjs.com
minorOct 3, 06:07 PM→Oct 4, 01:42 AMresolved
Oct 4, 01:42 AM
resolved — This incident has been resolved.
Oct 3, 06:07 PM
investigating — We are currently investigating this issue.
August 2025
Degraded Package Install Experience
minorAug 26, 12:40 PM→Aug 26, 03:49 PMresolved
Aug 26, 03:49 PM
resolved — This incident has been resolved.
Aug 26, 03:16 PM
monitoring — We are continuing to monitor for any further issues.
Aug 26, 03:15 PM
monitoring — A fix has been implemented and we are monitoring the results.
+3 more updates
Incident with npm registry and website affecting logins and publishing
minorAug 7, 10:31 PM→Aug 7, 11:05 PMresolved
Aug 7, 11:05 PM
resolved — This incident has been resolved.
Aug 7, 10:46 PM
monitoring — The issue has been identified and a remediation is being put into place.
Aug 7, 10:31 PM
investigating — We are currently investigating this issue.
June 2025
Issue with package publish with provenance
minorJun 12, 09:00 PM→Jun 12, 10:25 PMresolved
Jun 12, 10:25 PM
resolved — This incident has been resolved.
Jun 12, 09:00 PM
investigating — We are seeing issues with package publish with provenance due to an outage of a key third party dependency.
Issues with package install, package publish, and login.
majorJun 12, 06:14 PM→Jun 12, 08:58 PMresolved
Jun 12, 08:58 PM
resolved — This incident has been resolved.
Jun 12, 08:13 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 12, 07:15 PM
identified — The issue has been identified and a fix is being implemented.
+2 more updates
April 2025
Issues publishing and installing packages
minorApr 11, 02:46 AM→Apr 11, 02:51 PMresolved
Apr 11, 02:51 PM
resolved — This incident was caused due to an internal bug during regular database maintenance, its resolved now.
Apr 11, 12:52 PM
monitoring — We are monitoring results
Apr 11, 08:32 AM
identified — We are continuing to work on a fix to restore older access tokens.
+2 more updates
Issues publishing and installing packages
majorApr 5, 10:53 AM→Apr 5, 03:15 PMresolved
Apr 5, 03:15 PM
resolved — This incident has been resolved.
Apr 5, 01:34 PM
monitoring — A fix has been implemented and we are monitoring the results.
Apr 5, 12:00 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Intermittent issue with viewing and installing packages
minorApr 1, 04:40 PM→Apr 1, 07:40 PMresolved
Apr 1, 07:40 PM
resolved — This incident has been resolved.
Apr 1, 05:37 PM
monitoring — A fix has been implemented and we are monitoring the results.
Apr 1, 05:11 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
January 2025
npm is experiencing intermittent degraded installs
minorJan 8, 10:05 PM→Jan 9, 12:50 AMresolved
Jan 9, 12:50 AM
resolved — This incident has been resolved.
Jan 8, 11:12 PM
identified — The issue has been identified and a fix is being implemented.
Jan 8, 10:05 PM
investigating — We are currently investigating this issue
December 2024
Package Install failures due to "304 Not Modified" responses in Mumbai, India region
majorDec 17, 12:50 PM→Dec 17, 04:19 PMresolved
Dec 17, 04:19 PM
resolved — This incident has been resolved.
Dec 17, 03:43 PM
monitoring — A fix has been implemented and we are monitoring the results.
Dec 17, 02:37 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
November 2024
Intermittent issues with package install
minorNov 16, 01:31 PM→Nov 16, 02:58 PMresolved
Nov 16, 02:58 PM
resolved — This incident has been resolved.
Nov 16, 01:39 PM
monitoring — A fix has been implemented and we are monitoring the results.
Nov 16, 01:32 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
October 2024
Failures to publish packlages
minorOct 10, 08:25 PM→Oct 10, 09:40 PMresolved
Oct 10, 09:40 PM
resolved — This incident has been resolved.
Oct 10, 09:01 PM
monitoring — A fix has been implemented and we are monitoring the results.
Oct 10, 08:25 PM
identified — The issue has been identified and a fix is being implemented.
September 2024
Issue with publishing packages
minorSep 24, 10:49 PM→Sep 25, 12:37 AMresolved
Sep 25, 12:37 AM
resolved — This incident has been resolved.
Sep 25, 12:12 AM
monitoring — A fix has been implemented and we are monitoring the results.
Sep 25, 12:12 AM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
August 2024
README files not rendering on npmjs.com website
minorAug 9, 11:18 AM→Aug 9, 11:47 AMresolved
Aug 9, 11:47 AM
resolved — This incident has been resolved.
Aug 9, 11:23 AM
monitoring — A fix has been implemented and we are monitoring the results.
Aug 9, 11:18 AM
investigating — We are currently investigating this issue.
June 2024
Intermittent Issues with View Package
minorJun 20, 07:37 PM→Jun 20, 09:15 PMresolved
Jun 20, 09:15 PM
resolved — This incident has been resolved.
Jun 20, 08:27 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 20, 08:10 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Issue with search and replication feed
minorJun 17, 07:59 PM→Jun 17, 09:36 PMresolved
Jun 17, 09:36 PM
resolved — This incident has been resolved.
Jun 17, 09:14 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 17, 08:08 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Failures publishing, deprecating, and installing packages
majorJun 11, 03:09 PM→Jun 11, 04:44 PMresolved
Jun 11, 04:44 PM
resolved — This incident has been resolved.
Jun 11, 04:02 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 11, 03:28 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Intermittent failures installing scoped packages
majorJun 3, 05:55 PM→Jun 3, 07:38 PMresolved
Jun 3, 07:38 PM
resolved — This incident has been resolved.
Jun 3, 07:08 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 3, 06:21 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
May 2024
Issue with Private Package Installs
minorMay 3, 12:26 AM→May 3, 03:36 AMresolved
May 3, 03:36 AM
resolved — This incident has been resolved.
May 3, 02:57 AM
monitoring — A fix has been implemented and we are monitoring the results.
May 3, 12:26 AM
investigating — We are currently investigating an issue with private package installations.
April 2024
Issues publishing packages
noneApr 9, 09:01 PM→Apr 10, 12:44 AMresolved
Apr 10, 12:44 AM
resolved — This incident has been resolved.
Apr 9, 09:36 PM
monitoring — A fix has been implemented and we are monitoring the results.
Apr 9, 09:16 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
January 2024
npm support is down
minorJan 24, 05:56 PM→Jan 24, 07:37 PMresolved
Jan 24, 07:37 PM
resolved — This incident has been resolved.
Jan 24, 06:34 PM
monitoring — We are continuing to monitor for any further issues.
Jan 24, 06:33 PM
monitoring — A fix has been implemented and we are monitoring the results.
+2 more updates
December 2023
Degraded performance
minorDec 15, 10:32 PM→Dec 15, 11:13 PMresolved
Dec 15, 11:13 PM
resolved — This incident has been resolved.
Dec 15, 10:32 PM
monitoring — One of our providers is unfortunately experiencing increased error rates. This is affecting viewing of packages as well as package installs.
Issue installing and publishing private packages
majorDec 8, 07:13 PM→Dec 8, 08:35 PMresolved
Dec 8, 08:35 PM
resolved — This incident has been resolved.
Dec 8, 07:26 PM
monitoring — A fix has been implemented and we are monitoring the results.
Dec 8, 07:13 PM
investigating — We are currently investigating this issue.
November 2023
Email Verification is failing
minorNov 27, 03:07 PM→Nov 28, 01:07 AMresolved
Nov 28, 01:07 AM
resolved — This incident has been resolved.
Nov 27, 11:44 PM
monitoring — A fix has been implemented and we are monitoring the results.
Nov 27, 05:22 PM
investigating — There is an edge case which needs to be fixed
+3 more updates
Related Incident Histories
Get npm Registry Outage Alerts
Be the first to know when npm Registry go down.