Plaid Outage History
25 incidents reported. Data sourced from the official Plaid status page.
25
Total Incidents
7
Major/Critical
7
Minor
25
Resolved
August 2026
Service Disruption Impacting Bank of America connections
majorAug 2, 02:51 PM→Aug 3, 12:53 PMresolved
Aug 3, 12:53 PM
resolved — This incident has been resolved.
Aug 2, 02:51 PM
investigating — We are observing issues impacting new connections to Bank of America. We have notified Bank of America and are working to root cause and resolve this issue as quickly as possible.
python SDK degraded on Identity Verification APIs
minorAug 1, 01:34 AM→Aug 1, 02:56 AMresolved
Aug 1, 02:56 AM
resolved — A fix is deployed. This incident has been resolved.
Aug 1, 01:34 AM
identified — We've identified and issue causing degraded performance for our Python SDK (v33.0.0 and later) when retrieving Identity Verification results. We are deploying a fix.
July 2026
Virtual Account perfomance degradation (UK and Europe)
noneJul 27, 04:34 PM→Jul 28, 08:40 AMresolved
Jul 28, 08:40 AM
resolved — This incident has been resolved. Our services have returned to normal operations.
Jul 27, 10:09 PM
monitoring — We are observing improved performance and services are returning to normal operations. We are closely monitoring our systems as we recover.
Jul 27, 08:35 PM
identified — The incident is ongoing and we are working with our partner to restore service. You may continue to see issues with Refunds and Payouts. Settlement webhooks for pay-ins are also impacted.
+2 more updates
Transaction Updates Delayed
minorJul 22, 02:58 PM→Jul 24, 10:02 AMresolved
Jul 24, 10:02 AM
resolved — This incident is now resolved. The underlying issue has been fully mitigated, and all delayed default update webhooks have now been delivered. New item connections and their initial and historical tra...
Jul 24, 04:26 AM
monitoring — The third-party provider issue has been mitigated and recovery is progressing. New item connections and their initial and historical transaction webhooks are healthy and firing normally again, and new...
Jul 24, 02:22 AM
investigating — We are again experiencing delays in Transactions update webhooks due to a recurrence of the third-party service provider issue that caused the earlier degradation. We are working closely with the prov...
+10 more updates
Transfer Status Upates Delays
noneJul 23, 08:36 PM→Jul 23, 09:59 PMresolved
Jul 23, 09:59 PM
resolved — All impacted ACH and Same-day ACH transfers's status have been updated to posted. They will be marked as settled later today.
Jul 23, 08:36 PM
investigating — Transfer is experiencing delays affecting status updates for some Standard ACH and Same-Day ACH transfers created yesterday. Impacted Transfers were successfully settled on ACH network. Transfer creat...
Payouts/Refunds API degraded
noneJul 23, 11:41 AM→Jul 23, 02:33 PMresolved
Jul 23, 02:33 PM
resolved — This incident has been resolved.
Jul 23, 02:28 PM
monitoring — This incident has been resolved.
Jul 23, 12:25 PM
monitoring — This issue has been mitigated. We are closely monitoring our systems as we recover.
+2 more updates
Link performance degradation
noneJul 17, 11:59 PM→Jul 18, 01:39 AMresolved
Jul 18, 01:39 AM
resolved — This incident has been resolved.
Jul 17, 11:59 PM
investigating — We are experiencing degraded performance with Link.
Some users are seeing issues with Link, where when users completes an OAuth flow with a bank, Plaid Link may crash and restart, prompting users to ...
Elevated dashboard.plaid.com error rates
majorJul 16, 08:48 AM→Jul 16, 10:30 AMresolved
Jul 16, 10:30 AM
resolved — SSO and Google logins in the Plaid Dashboard are now performing as normal.
Jul 16, 09:30 AM
monitoring — SSO and Google logins on the Plaid Dashboard are now working with increased latency. We'll continue to monitor until fully recovered.
Jul 16, 09:22 AM
identified — We are experiencing elevated error rates on the Plaid Dashboard during SSO and Google logins. We are working on a resolution.
+1 more updates
Elevated API errors
noneJul 12, 03:06 AM→Jul 12, 05:57 AMresolved
Jul 12, 05:57 AM
resolved — This incident has been resolved.
Jul 12, 03:06 AM
investigating — We are currently experiencing elevated error rates for Document Income API calls. We are actively investigating and working to mitigate this issue.
Service Disruption Impacting Chase connections
majorJul 12, 12:43 AM→Jul 12, 12:45 AMresolved
Jul 12, 12:45 AM
resolved — This incident has been resolved.
Jul 12, 12:43 AM
investigating — Chase is currently experiencing downtime impacting all channels and data recipients. Item adds and API calls through Plaid are impacted. We will provide an update when Chase has resolved the issue.
Service Disruption Impacting Wells Fargo connections
majorJul 11, 01:56 AM→Jul 11, 02:16 AMresolved
Jul 11, 02:16 AM
resolved — This incident has been resolved.
Jul 11, 01:56 AM
investigating — Wells Fargo is currently experiencing downtime impacting all channels and data recipients. Item adds through Plaid are impacted. We will provide an update when Wells Fargo has resolved the issue.
IDV Performance Degradation
noneJul 10, 06:46 PM→Jul 10, 09:40 PMresolved
Jul 10, 09:40 PM
resolved — This incident has been resolved.
Jul 10, 06:46 PM
monitoring — Identity Verification experienced a degradation in performance affecting Document checks between 16:37 UTC and 18:05 UTC. Performance has been restored. We are closely monitoring our systems as we rec...
Elevated Item add errors
minorJul 10, 04:51 PM→Jul 10, 09:38 PMresolved
Jul 10, 09:38 PM
resolved — This incident has been resolved.
Jul 10, 05:46 PM
monitoring — This issue has been mitigated. We are closely monitoring our systems as we recover.
Jul 10, 04:51 PM
identified — We have identified the root cause of the issue and are actively working to mitigate the impact.
Service Disruption Impacting Wells Fargo connections
majorJul 10, 04:04 PM→Jul 10, 07:23 PMresolved
Jul 10, 07:23 PM
resolved — This incident has been resolved.
Jul 10, 04:04 PM
investigating — Wells Fargo is currently experiencing downtime impacting all channels and data recipients. Item adds and API calls through Plaid are impacted. We will provide an update when Wells Fargo has resolved t...
June 2026
Elevated Item add errors
minorJun 8, 06:53 PM→Jun 8, 06:56 PMresolved
Jun 8, 06:56 PM
resolved — This incident has been resolved.
Jun 8, 06:53 PM
monitoring — We were experiencing elevated error rates. This issue has been mitigated. We are closely monitoring our systems as we recover.
Service Disruption Impacting Wells Fargo connections
majorJun 5, 02:24 AM→Jun 5, 06:21 AMresolved
Jun 5, 06:21 AM
resolved — This incident has been resolved.
Jun 5, 02:24 AM
identified — Wells Fargo is currently experiencing downtime impacting all channels and data recipients. Item adds through Plaid are impacted. We will provide an update when Wells Fargo has resolved the issue.
May 2026
Service Disruption Impacting Chase connections
noneMay 26, 10:42 PM→May 27, 12:02 AMresolved
May 27, 12:02 AM
resolved — This incident has been resolved.
May 26, 10:42 PM
investigating — Chase is currently experiencing downtime impacting all channels and data recipients. Connections through Plaid are impacted. We will provide an update when Chase has resolved the issue.
Issues retrieving invoices on the Dashboard Billing page
noneMay 26, 11:13 PM→May 26, 11:00 PMresolved
May 26, 11:13 PM
resolved — We experienced problems retrieving invoices on the Billing section of the Plaid dashboard between Thursday, May 21, 2026 12:00 PT - Tuesday, May 26, 2026 15:40 PT. This incident has been resolved.
Service Disruption Impacting Chase connections
majorMay 26, 10:33 PM→May 26, 10:42 PMresolved
May 26, 10:42 PM
resolved — This incident has been resolved.
May 26, 10:33 PM
investigating — Chase is currently experiencing downtime impacting all channels and data recipients. Item adds and API calls through Plaid are impacted. We will provide an update when Chase has resolved the issue.
Transaction Updates Delayed
noneMay 21, 07:33 PM→May 22, 12:30 AMresolved
May 22, 12:30 AM
resolved — This incident has been resolved.
May 21, 07:33 PM
investigating — We are currently experiencing delays in Transactions updates. We are actively investigating and working to mitigate this issue.
Increased Transactions webhook latency
noneMay 21, 07:36 PM→May 22, 12:30 AMresolved
May 22, 12:30 AM
resolved — This incident has been resolved.
May 21, 08:30 PM
monitoring — We have mitigated the the issue of elevated latency for the INITIAL_UPDATE and HISTORICAL_UPDATE Transactions webhooks. We are closely monitoring our systems as we recover.
May 21, 08:12 PM
investigating — We have identified the root cause of the issue and are actively working to mitigate the impact.
+1 more updates
Elevated API errors on signal/evaluate and protect/compute
minorMay 14, 04:13 AM→May 14, 06:13 AMresolved
May 14, 06:13 AM
resolved — This incident has been resolved.
May 14, 04:44 AM
identified — We are currently experiencing elevated error rates for Signal and Protect API calls. We are actively investigating and working to mitigate this issue.
May 14, 04:13 AM
investigating — We are currently experiencing elevated error rates for Signal API calls (signal/evaluate). We are actively investigating and working to mitigate this issue.
Dashboard sessions are degraded
noneMay 10, 11:27 PM→May 10, 11:39 PMresolved
May 10, 11:39 PM
resolved — We are experiencing elevated error rates on the Plaid Dashboard. We are actively investigating this issue.
May 10, 11:27 PM
identified — Dashboard sessions are intermittently degraded. We are rolling out a fix
Elevated API errors
minorMay 8, 02:18 AM→May 9, 07:26 AMresolved
May 9, 07:26 AM
resolved — This incident has been resolved.
May 8, 06:26 AM
monitoring — This issue affected traffic for approximately 5 minutes and was mitigated. We are closely monitoring our systems as we recover.
May 8, 02:18 AM
investigating — We are currently experiencing elevated error rates for API calls. We are actively investigating and working to mitigate this issue.
Elevated dashboard.plaid.com error rates
minorMay 8, 01:37 AM→May 9, 07:24 AMresolved
May 9, 07:24 AM
resolved — This incident has been resolved.
May 8, 02:40 PM
monitoring — We are experiencing elevated error rates on the Plaid Dashboard. We are actively investigating this issue.
May 8, 01:37 AM
investigating — We are experiencing elevated error rates on the Plaid Dashboard. We are actively investigating this issue.
Related Incident Histories
Get Plaid Outage Alerts
Be the first to know when Plaid go down.