Reddit API Outage History
50 incidents reported. Data sourced from the official Reddit API status page.
50
Total Incidents
22
Major/Critical
18
Minor
50
Resolved
September 2026
Elevated site errors
majorSep 1, 07:51 PM→Sep 1, 09:24 PMresolved
Sep 1, 09:24 PM
resolved — This incident has been resolved.
Sep 1, 09:07 PM
monitoring — A fix has been implemented and we are monitoring the results.
Sep 1, 07:51 PM
investigating — We are currently investigating this issue.
July 2026
Degraded performance across the site
majorJul 25, 03:05 PM→Jul 25, 04:26 PMresolved
Jul 25, 04:26 PM
resolved — This incident has been resolved.
Jul 25, 04:14 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jul 25, 03:33 PM
identified — We've mitigated the issue, but not out of the woods yet
+2 more updates
May 2026
Investigating elevated errors and issues loading comments
noneMay 20, 08:58 PM→May 20, 09:57 PMresolved
May 20, 09:57 PM
resolved — This issue is now resolved. Errors have subsided and we're seeing consistent loading across comments.
May 20, 09:37 PM
monitoring — Most errors have cleared up and comments should be appearing as expected. We're continuing to monitor the situation.
May 20, 09:22 PM
identified — We've identified the issue and you should now start to see comments load properly again. We're still monitoring the situation!
+2 more updates
Investigating elevated site errors and issues accessing media
minorMay 18, 05:39 PM→May 18, 09:04 PMresolved
May 18, 09:04 PM
resolved — This issue is now resolved. We're seeing consistent loading across feeds, posts and search. Media should now be appearing as expected.
May 18, 07:44 PM
monitoring — A fix has been implemented and we're seeing recovery. We're continuing to monitor the situation!
May 18, 06:06 PM
identified — The issue has been identified and we are working on implementing a fix. While this is ongoing, you may encounter errors and general loading issues across feeds, posts, and search. Recently uploaded im...
+1 more updates
AWS availability causing degradation in user experiences for various services
minorMay 8, 12:47 AM→May 11, 02:26 PMresolved
May 11, 02:26 PM
resolved — This incident has been resolved.
May 9, 04:32 PM
monitoring — A fix has been implemented and we are monitoring the results.
May 8, 11:12 AM
identified — We have mitigated issues caused by the AWS us-east-1 outage but continue to monitor as AWS has not yet fully recovered.
+2 more updates
Search experience and subreddit experience is degraded
noneMay 5, 11:44 PM→May 6, 12:18 AMresolved
May 6, 12:18 AM
resolved — This incident has been resolved.
May 6, 12:03 AM
monitoring — A fix has been implemented and we are monitoring the results.
May 5, 11:45 PM
identified — We have identified the issue and a fix is being implemented.
+1 more updates
April 2026
Issues with reporting
majorApr 30, 07:32 PM→Apr 30, 08:09 PMresolved
Apr 30, 08:09 PM
resolved — This incident has been resolved.
Apr 30, 07:53 PM
monitoring — A fix has been implemented and we are monitoring the results.
Apr 30, 07:32 PM
investigating — Users may experience issues when trying to report posts, comments, or user details.
Elevated Site Errors
noneApr 7, 08:18 PM→Apr 7, 08:54 PMresolved
Apr 7, 08:54 PM
resolved — This incident has been resolved.
Apr 7, 08:27 PM
monitoring — A fix has been implemented and we are monitoring the results.
Apr 7, 08:22 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Elevated site Errors
majorApr 6, 06:49 PM→Apr 6, 07:57 PMresolved
Apr 6, 07:57 PM
resolved — This incident has been resolved.
Apr 6, 07:03 PM
monitoring — A fix has been implemented and we are monitoring the results.
Apr 6, 06:58 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
March 2026
Degraded performance for reddit.com
majorMar 4, 12:35 AM→Mar 4, 12:46 AMresolved
Mar 4, 12:46 AM
resolved — This incident has been resolved.
Mar 4, 12:39 AM
monitoring — A fix has been implemented and we are monitoring the results.
Mar 4, 12:35 AM
investigating — We are currently investigating this issue.
January 2026
Elevated Errors
noneJan 18, 09:33 PM→Jan 18, 09:44 PMresolved
Jan 18, 09:44 PM
resolved — This incident has been resolved.
Jan 18, 09:43 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jan 18, 09:42 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Increased error rates across the site
majorJan 17, 12:20 AM→Jan 17, 03:37 AMresolved
Jan 17, 03:37 AM
resolved — Everything is now resolved.
Jan 17, 01:23 AM
identified — Users are experiencing increased error rates when posting images in comments or posts, signing up for accounts, or deleting accounts. We've identified the underlying cause and are working on a resolut...
Jan 17, 12:20 AM
identified — Users are experiencing increased error rates when posting images or signing up for accounts. We've identified the underlying cause and are working on a resolution.
Investigating elevated errors across reddit.com and native apps
minorJan 13, 05:01 PM→Jan 13, 06:04 PMresolved
Jan 13, 06:04 PM
resolved — This incident has been resolved.
Jan 13, 05:53 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jan 13, 05:03 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
December 2025
Video posts are not displaying correctly
minorDec 18, 10:49 PM→Dec 19, 01:00 AMresolved
Dec 19, 01:00 AM
resolved — A fix has been rolled out and we have fixed the issues with impacted video posts.
Dec 18, 11:06 PM
identified — We've identified and mitigated the underlying problem. Newly uploaded videos should now appear correctly, and we're working on a fix for videos uploaded during the outage.
Dec 18, 10:49 PM
investigating — We are currently investigating reports that some video posts are displaying as images.
Elevated errors
majorDec 9, 06:28 PM→Dec 9, 07:02 PMresolved
Dec 9, 07:02 PM
resolved — This incident has been resolved.
Dec 9, 06:28 PM
investigating — We are currently investigating this issue.
Elevated errors
minorDec 9, 05:05 AM→Dec 9, 06:01 AMresolved
Dec 9, 06:01 AM
resolved — This incident has been resolved.
Dec 9, 05:27 AM
monitoring — A fix has been implemented and we are monitoring the results.
Dec 9, 05:05 AM
investigating — We are currently investigating this issue.
November 2025
iOS Push Notifications Not Working
minorNov 30, 06:48 PM→Nov 30, 11:59 PMresolved
Nov 30, 11:59 PM
resolved — This incident has been resolved.
Nov 30, 10:45 PM
monitoring — We are largely back up and are monitoring to ensure the problem is resolved completely
Nov 30, 07:25 PM
identified — We have identified the root cause, began a fix, and have seen a small uptick in push notifications being delivered to iOS
+1 more updates
Increased error rates on Reddit
minorNov 4, 12:27 PM→Nov 4, 01:17 PMresolved
Nov 4, 01:17 PM
resolved — This incident has been resolved.
Nov 4, 01:05 PM
monitoring — We are continuing to monitor for any further issues.
Nov 4, 01:04 PM
monitoring — A fix has been implemented and we are monitoring the results.
+2 more updates
October 2025
Elevated errors
majorOct 20, 10:24 AM→Oct 20, 11:09 PMresolved
Oct 20, 11:09 PM
resolved — This incident has been resolved.
Oct 20, 11:10 AM
monitoring — We are continuing to monitor for any further issues.
Oct 20, 11:10 AM
monitoring — A fix has been implemented and we are monitoring the results.
+1 more updates
August 2025
Elevated errors with comments
majorAug 25, 11:15 PM→Aug 25, 11:55 PMresolved
Aug 25, 11:55 PM
resolved — This incident has been resolved.
Aug 25, 11:26 PM
monitoring — A fix has been implemented and we are monitoring the results.
Aug 25, 11:17 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
July 2025
Elevated errors with comments
majorJul 16, 11:16 PM→Jul 17, 05:42 AMresolved
Jul 17, 05:42 AM
resolved — This incident has been resolved.
Jul 16, 11:49 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jul 16, 11:16 PM
investigating — We are currently investigating this issue.
Investigating elevated site errors
majorJul 16, 03:52 PM→Jul 16, 04:38 PMresolved
Jul 16, 04:38 PM
resolved — This incident has been resolved.
Jul 16, 04:21 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jul 16, 04:07 PM
identified — We've identified the cause of the issue and are working to address it.
+1 more updates
June 2025
Elevated Errors
noneJun 19, 06:24 PM→Jun 19, 07:21 PMresolved
Jun 19, 07:21 PM
resolved — This incident has been resolved.
Jun 19, 06:55 PM
identified — The issue has been identified and a fix is being implemented. Comments will be delayed while our systems catch up.
Jun 19, 06:24 PM
investigating — We're experiencing an elevated level of errors and are currently looking into the issue. Comments are currently not publishing on the site.
Elevated errors
criticalJun 3, 07:00 PM→Jun 3, 07:29 PMresolved
Jun 3, 07:29 PM
resolved — This incident has been resolved.
Jun 3, 07:14 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jun 3, 07:00 PM
investigating — We are currently investigating this issue.
May 2025
Errors viewing image posts on mobile clients
majorMay 28, 05:07 PM→May 28, 05:59 PMresolved
May 28, 05:59 PM
resolved — This incident has been resolved.
May 28, 05:40 PM
identified — The cause has been identified and we are taking steps to mitigate this issue.
May 28, 05:07 PM
investigating — We are continuing to investigate this issue.
+1 more updates
Elevated Errors
majorMay 16, 10:47 PM→May 16, 11:53 PMresolved
May 16, 11:53 PM
resolved — This incident has been resolved.
May 16, 11:22 PM
monitoring — A fix has been implemented and we are monitoring the results.
May 16, 11:14 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
April 2025
Chat - elevated errors
majorApr 30, 12:58 PM→Apr 30, 01:34 PMresolved
Apr 30, 01:34 PM
resolved — This incident has been resolved.
Apr 30, 01:05 PM
monitoring — A fix has been implemented and we are monitoring the results.
Apr 30, 01:03 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Investigating elevated site errors
majorApr 21, 03:52 PM→Apr 21, 04:21 PMresolved
Apr 21, 04:21 PM
resolved — This incident has been resolved.
Apr 21, 04:10 PM
monitoring — A fix has been implemented and we are monitoring results.
Apr 21, 04:01 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Missing Action Buttons For Moderators
minorApr 2, 07:20 PM→Apr 2, 09:31 PMresolved
Apr 2, 09:31 PM
resolved — This incident has been resolved.
Apr 2, 09:20 PM
monitoring — A fix has been implemented and we are monitoring the results.
Apr 2, 07:20 PM
identified — Moderators are experiencing issues loading comment pages and moderating comments in their communities
March 2025
Degraded performance for reddit.com
noneMar 27, 07:16 PM→Mar 28, 10:54 AMresolved
Mar 28, 10:54 AM
resolved — This incident has been resolved.
Mar 27, 07:48 PM
monitoring — A fix has been implemented and we are monitoring the results.
Mar 27, 07:16 PM
investigating — We are currently investigating this issue.
Degraded performance for comments
minorMar 25, 05:06 PM→Mar 25, 07:30 PMresolved
Mar 25, 07:30 PM
resolved — This incident has been resolved.
Mar 25, 05:36 PM
monitoring — A fix has been implemented and we are monitoring the results.
Mar 25, 05:06 PM
investigating — We are currently investigating this issue.
Elevated Errors
minorMar 24, 09:29 PM→Mar 24, 09:52 PMresolved
Mar 24, 09:52 PM
resolved — This incident has been resolved.
Mar 24, 09:33 PM
identified — The issue has been identified and a fix is being implemented.
Mar 24, 09:29 PM
investigating — We're experiencing an elevated level of API errors and are currently looking into the issue. You may notice a lag in comment publishing.
Delayed Comments
majorMar 1, 11:01 AM→Mar 1, 12:34 PMresolved
Mar 1, 12:34 PM
resolved — This incident has been resolved.
Mar 1, 12:00 PM
monitoring — Comments processing has caught up and we are now operating normally.
Mar 1, 11:24 AM
identified — We have identified the issue and are deploying a fix.
+1 more updates
February 2025
Elevated Errors
noneFeb 24, 06:37 PM→Feb 24, 07:54 PMresolved
Feb 24, 07:54 PM
resolved — This incident has been resolved.
Feb 24, 06:47 PM
monitoring — A fix has been implemented and we are monitoring the results.
Feb 24, 06:43 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Elevated Errors
majorFeb 22, 12:58 AM→Feb 22, 02:47 AMresolved
Feb 22, 02:47 AM
resolved — This incident has been resolved.
Feb 22, 01:40 AM
identified — The issue has been identified and a fix is being implemented.
Feb 22, 12:58 AM
investigating — We're experiencing an elevated level of errors and are currently looking into the issue.
Increase in errors
noneFeb 18, 10:17 PM→Feb 18, 10:57 PMresolved
Feb 18, 10:57 PM
resolved — This incident has been resolved.
Feb 18, 10:34 PM
monitoring — A fix has been implemented and we are monitoring the results.
Feb 18, 10:30 PM
identified — We have identified the issue and are implementing repairs.
+1 more updates
January 2025
Site issues
noneJan 17, 09:09 AM→Jan 17, 10:36 AMresolved
Jan 17, 10:36 AM
resolved — This incident has been resolved.
Jan 17, 09:32 AM
monitoring — Issues with the r/popular feed have been mitigated.
Jan 17, 09:09 AM
investigating — We are currently investigating degraded performance of r/popular.
November 2024
Degraded performance for reddit.com
minorNov 21, 03:51 PM→Nov 21, 04:19 PMresolved
Nov 21, 04:19 PM
resolved — We have fixed the problem and have returned to normal operation.
Nov 21, 04:15 PM
identified — We have identified the issue and are implementing repairs.
Nov 21, 03:51 PM
investigating — We are currently investigating a problem with our site.
Degraded performance for reddit.com
minorNov 20, 08:38 PM→Nov 21, 04:08 AMresolved
Nov 21, 04:08 AM
resolved — This incident has been resolved.
Nov 21, 12:35 AM
monitoring — A fix has been implemented and we are monitoring the results.
Nov 20, 08:38 PM
investigating — We are currently investigating this issue.
Degraded performance for reddit.com
majorNov 6, 04:07 AM→Nov 6, 01:00 PMresolved
Nov 6, 01:00 PM
resolved — This incident has been resolved.
Nov 6, 12:47 PM
monitoring — We are keeping an eye on site stability, but functionality should be restored.
Nov 6, 09:41 AM
identified — We are continuing to implement fixes to restore site functionality. Some features may continue to be degraded.
+2 more updates
October 2024
Web performance degraded
noneOct 14, 08:12 AM→Oct 14, 03:33 PMresolved
Oct 14, 03:33 PM
resolved — This incident has been resolved.
Oct 14, 08:12 AM
investigating — We are currently experience a performance degradation of our service. We are working to fix the problem.
September 2024
Degraded Performance for reddit.com
minorSep 19, 07:15 PM→Sep 19, 08:22 PMresolved
Sep 19, 08:22 PM
resolved — This incident has been resolved.
Sep 19, 08:09 PM
monitoring — We have identified the underlying cause of the issues and have rolled out a fix.
Sep 19, 07:15 PM
investigating — We are currently investigating this issue.
August 2024
Degraded Performance for reddit.com
criticalAug 28, 08:16 PM→Aug 28, 09:16 PMresolved
Aug 28, 09:16 PM
resolved — This incident has been resolved.
Aug 28, 08:45 PM
monitoring — A fix has been implemented and we are monitoring the results.
Aug 28, 08:32 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Degraded Performance for reddit.com
minorAug 13, 08:51 PM→Aug 13, 10:02 PMresolved
Aug 13, 10:02 PM
resolved — This incident has been resolved.
Aug 13, 09:29 PM
monitoring — A fix has been implemented and we are monitoring the results.
Aug 13, 09:06 PM
investigating — We are continuing to investigate this issue.
+1 more updates
Some subreddits/posts are failing to load
minorAug 6, 06:36 PM→Aug 6, 07:27 PMresolved
Aug 6, 07:27 PM
resolved — The fix has rolled out completely, and things are back to normal.
Aug 6, 07:13 PM
identified — A fix is in the process of rolling out, we should be back to normal in 15-20 minutes.
Aug 6, 06:36 PM
identified — Some posts/subreddits are currently failing to load for web and mobile users. We've identified a likely culprit and are currently working to address it.
July 2024
Comment Processing is Delayed
majorJul 14, 12:24 AM→Jul 14, 01:51 AMresolved
Jul 14, 01:51 AM
resolved — We're confident things are as normal as can be, back to posting!
Jul 14, 01:41 AM
monitoring — We've eaten through the backlog of comments. We should be operating as normal.
Jul 14, 01:25 AM
identified — We've identified the issue and are deploying mitigations. Hang tight as delayed comments are being processed.
+1 more updates
Elevated API Errors
minorJul 8, 06:43 PM→Jul 8, 07:54 PMresolved
Jul 8, 07:54 PM
resolved — This incident has been resolved.
Jul 8, 07:19 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jul 8, 06:43 PM
identified — We're experiencing an elevated level of API errors and are currently looking into the issue.
June 2024
Comment tree processing is delayed
majorJun 28, 02:17 AM→Jun 28, 05:05 AMresolved
Jun 28, 05:05 AM
resolved — Comment processing has now fully caught up. Thank you for your patience!
Jun 28, 04:31 AM
identified — A large spike in traffic caused some scaling issues, which delayed new comment display across the site. All comments posted during this time will be displayed as the servers work through the backlog...
Jun 28, 04:08 AM
identified — We are continuing to work on addressing the issues causing comments to be delayed.
+2 more updates
May 2024
Issues with new post creation
minorMay 16, 08:12 PM→May 16, 08:43 PMresolved
May 16, 08:43 PM
resolved — We have identified the underlying issue and implemented a fix. Posts which were missing media when created should have that media restored now.
May 16, 08:12 PM
investigating — We are investigating reports that new posts with media are not being created correctly.
Post Detail Issues
minorMay 3, 07:46 PM→May 3, 09:27 PMresolved
May 3, 09:27 PM
resolved — This incident has been resolved.
May 3, 08:19 PM
monitoring — We're implementing a fix and monitoring for recovery.
May 3, 07:57 PM
identified — We've identified the issue and are working to implement a fix.
+1 more updates
Related Incident Histories
Get Reddit API Outage Alerts
Be the first to know when Reddit API go down.