Twitch API Outage History

50 incidents reported. Data sourced from the official Twitch API status page.

50
Total Incidents
17
Major/Critical
12
Minor
50
Resolved

September 2026

Identified Checkout Issues

major
Sep 16, 03:58 PMSep 16, 06:47 PMresolved
Sep 16, 06:47 PM
resolved🛠 We have resolved all known issues causing some users to be unable to checkout.
Sep 16, 03:58 PM
investigating🛠 We have identified an issue causing some users to be unable to checkout on Android devices. We're currently working to resolve this issue.

Watch Streak/Channel Points downtime

none
Sep 3, 03:00 PMSep 3, 03:00 PMresolved
Sep 3, 06:09 PM
resolvedWe've fixed an issue where watching streams/VODs during did not extend watch streaks or award Channel Points

August 2026

Service Negatively Impacted

critical
Aug 27, 08:09 PMAug 28, 02:31 AMresolved
Aug 28, 02:31 AM
resolved🛠 We have resolved all known negative service impacts.
Aug 27, 10:03 PM
monitoringA fix has been implemented and we are monitoring the results.
Aug 27, 08:09 PM
investigatingWe have received reports of impacted services. This could manifest in chat not working, login difficulties, search impaired, etc. We're looking into the issue.

March 2026

Identified Checkout Issues

none
Mar 31, 06:09 PMMar 31, 07:02 PMresolved
Mar 31, 07:02 PM
resolvedThis incident has been resolved.
Mar 31, 06:09 PM
investigating🛠 We have identified an issue causing some users to be unable to checkout. We're currently working to resolve this issue.

June 2025

Identified Web Issues

minor
Jun 12, 05:38 PMJun 12, 06:28 PMresolved
Jun 12, 06:28 PM
resolved🛠 We have resolved all known issues causing the Twitch website to fail to load for some users.
Jun 12, 06:24 PM
monitoringA fix has been implemented and we are monitoring the results.
Jun 12, 05:39 PM
identifiedWe are continuing to work on a fix for this issue.
+1 more updates

September 2024

Identified Web Issues

major
Sep 25, 08:16 PMSep 25, 09:23 PMresolved
Sep 25, 09:23 PM
resolved🛠 We have resolved all known issues causing the Twitch website to fail to load for some users.
Sep 25, 08:16 PM
identified🛠 We have identified an issue causing Twitch to fail to load in some cases.

August 2024

Resolved Service Impact

none
Aug 29, 05:23 PMAug 30, 10:30 AMresolved
Aug 29, 05:23 PM
resolved🛠 We have resolved all known negative service impacts.

Service Negatively Impacted

none
Aug 29, 08:30 AMAug 29, 08:30 AMresolved
Aug 29, 05:22 PM
resolvedWe have received reports of impacted services. This could manifest in chat not working, login difficulties, search impaired, etc. We're looking into the issue.

Resolved Chat Issues

none
Aug 19, 12:30 PMAug 19, 12:30 PMresolved
Aug 19, 04:34 PM
resolved🛠 We have resolved all known issues causing chat to not work, go forth and kappa.

December 2023

Identified Video (Watching) Issues

none
Dec 31, 05:25 PMDec 31, 05:37 PMresolved
Dec 31, 05:37 PM
resolvedThis incident has been resolved.
Dec 31, 05:25 PM
identified🛠 We have identified an issue preventing people from watching streams on Twitch. We're currently working to resolve this issue.

Identified Web Issues

major
Dec 10, 03:24 AMDec 10, 04:14 AMresolved
Dec 10, 04:14 AM
resolvedThis incident has been resolved.
Dec 10, 03:49 AM
monitoringA fix has been implemented and we are monitoring the results.
Dec 10, 03:24 AM
identified🛠 We have identified an issue causing Twitch to fail to load in some cases.

Identified Purchases Issues

major
Dec 7, 01:54 AMDec 7, 03:00 AMresolved
Dec 7, 03:00 AM
resolved🛠 We have resolved all known issues causing people to be unable to make purchases.
Dec 7, 01:54 AM
identified🛠 We have identified an issue causing some users to be unable to make purchases. We're currently working to resolve this issue.

November 2023

Identified Video (Watching) Issues

critical
Nov 7, 06:09 PMNov 7, 09:49 PMresolved
Nov 7, 09:49 PM
resolvedThis incident has been resolved.
Nov 7, 09:34 PM
monitoringA fix has been implemented and we are monitoring the results.
Nov 7, 06:09 PM
identified🛠 We have identified an issue preventing people from watching streams on Twitch. We're currently working to resolve this issue.

September 2023

Identified Video (Watching) Issues

none
Sep 11, 05:04 PMSep 11, 05:31 PMresolved
Sep 11, 05:31 PM
resolvedThis incident has been resolved.
Sep 11, 05:09 PM
monitoringA fix has been implemented and we are monitoring the results.
Sep 11, 05:04 PM
identified🛠 We have identified an issue preventing people from watching streams on Twitch. We're currently working to resolve this issue.

July 2023

Identified Video (Watching) Issues

none
Jul 25, 02:22 PMJul 25, 05:24 PMresolved
Jul 25, 05:24 PM
resolved🛠 We've resolved all known issues of Vods not playing across Twitch.
Jul 25, 03:24 PM
investigating🛠 We've resolved all known issues of Vods not playing across Twitch.
Jul 25, 02:54 PM
monitoringA fix has been implemented and we are monitoring the results.
+1 more updates

Identified Purchases Issues

major
Jul 6, 11:25 PMJul 7, 12:33 AMresolved
Jul 7, 12:33 AM
resolved🛠 We have resolved all known issues causing people to be unable to make purchases.
Jul 7, 12:10 AM
monitoringA fix has been implemented and we are monitoring the results.
Jul 6, 11:25 PM
identified🛠 We have identified an issue causing some users to be unable to make purchases. We're currently working to resolve this issue.

Service Negatively Impacted

none
Jul 1, 05:12 PMJul 1, 11:14 PMresolved
Jul 1, 11:14 PM
resolvedThis incident has been resolved.
Jul 1, 08:01 PM
investigatingWe are continuing to investigate this issue.
Jul 1, 06:38 PM
investigatingWe are continuing to investigate this issue.
+2 more updates

June 2023

Identified Video (Broadcasting) Issues

none
Jun 27, 04:15 PMJun 27, 05:04 PMresolved
Jun 27, 05:04 PM
resolvedThis incident has been resolved.
Jun 27, 05:00 PM
monitoringA fix has been implemented and we are monitoring the results.
Jun 27, 04:15 PM
identified🛠 We have identified an issue preventing people from broadcasting on Twitch. We're currently working to resolve this issue.

April 2023

Identified Checkout Issues

minor
Apr 25, 06:54 AMApr 25, 09:13 AMresolved
Apr 25, 09:13 AM
resolvedThis incident has been resolved.
Apr 25, 06:54 AM
monitoring🛠 We have identified an issue causing some users to be unable to checkout. We're currently working to resolve this issue.

Identified Login Issues

major
Apr 12, 07:22 PMApr 12, 07:49 PMresolved
Apr 12, 07:49 PM
resolvedThis incident has been resolved.
Apr 12, 07:45 PM
monitoringA fix has been implemented and we are monitoring the results.
Apr 12, 07:44 PM
identifiedThe issue has been identified and a fix is being implemented.
+1 more updates

January 2023

Identified Video (Broadcasting) Issues

minor
Jan 5, 09:51 PMJan 5, 10:54 PMresolved
Jan 5, 10:54 PM
resolvedThis incident has been resolved.
Jan 5, 10:31 PM
monitoringA fix has been implemented and we are monitoring the results.
Jan 5, 09:51 PM
identified🛠 We have identified an issue preventing people from broadcasting on Twitch. We're currently working to resolve this issue.

Service Negatively Impacted

critical
Jan 3, 06:44 PMJan 3, 07:23 PMresolved
Jan 3, 07:23 PM
resolvedThis incident has been resolved.
Jan 3, 06:44 PM
investigatingWe have received reports of impacted services. This could manifest in chat not working, login difficulties, search impaired, etc. We're looking into the issue.

November 2022

Identified Mobile Issues

none
Nov 28, 10:44 PMNov 29, 01:03 AMresolved
Nov 29, 01:03 AM
resolvedThis incident has been resolved.
Nov 28, 10:44 PM
investigating🛠 We have identified an issue affecting mobile users. We're currently working to resolve this issue.

Identified Login Issues

none
Nov 4, 08:44 PMNov 4, 09:39 PMresolved
Nov 4, 09:39 PM
resolvedThis incident has been resolved.
Nov 4, 09:32 PM
monitoringA fix has been implemented and we are monitoring the results.
Nov 4, 08:44 PM
identified🛠 We have identified an issue where some users are unable to log in. We're currently working to resolve this issue.

Video (VOD) Issues - Identified

none
Nov 3, 08:23 PMNov 3, 11:39 PMresolved
Nov 3, 11:39 PM
resolvedThis incident has been resolved.
Nov 3, 08:59 PM
monitoringWe are continuing to monitor for any further issues.
Nov 3, 08:58 PM
monitoringA fix has been implemented and we are monitoring the results.
+2 more updates

Identified Chat Issues

minor
Nov 2, 08:37 PMNov 3, 12:36 AMresolved
Nov 3, 12:36 AM
resolvedThis incident has been resolved.
Nov 2, 08:37 PM
identified🛠 We have identified an issue causing chat to not work for some users. We're currently working to resolve this issue.

October 2022

Resolved Service Impact

none
Oct 28, 04:30 PMOct 28, 04:30 PMresolved
Oct 28, 06:13 PM
resolvedWe have received reports of impacted services. This could manifest in chat not working, login difficulties, search impaired, etc. We're looking into the issue. 🛠 We have resolved all known negative...

September 2022

Identified Video (Broadcasting) Issues

minor
Sep 28, 05:06 PMSep 28, 11:19 PMresolved
Sep 28, 11:19 PM
resolvedThis incident has been resolved.
Sep 28, 09:17 PM
monitoringA fix has been implemented and we are monitoring the results.
Sep 28, 08:51 PM
identifiedWe are continuing to work on a fix for this issue.
+5 more updates

Identified Android Purchase Issues

minor
Sep 20, 11:16 PMSep 21, 03:45 AMresolved
Sep 21, 03:45 AM
resolvedThis incident has been resolved.
Sep 20, 11:16 PM
identified🛠 We have identified an issue affecting Android users. We're currently working to resolve this issue.

OCE Service Negatively Impacted

none
Sep 14, 11:41 AMSep 14, 01:02 PMresolved
Sep 14, 01:02 PM
resolvedThis incident has been resolved.
Sep 14, 12:38 PM
monitoringA fix has been implemented and we are monitoring the results.
Sep 14, 11:41 AM
identifiedWe have received reports of impacted service in Oceania. This could manifest in video not loading, search impaired, etc. We're looking into the issue.

August 2022

Identified Video (Broadcasting) Issues

major
Aug 24, 09:34 PMAug 24, 11:17 PMresolved
Aug 24, 11:17 PM
resolved🛠 We've resolved all known issues of broadcasters not being able to stream on Twitch.
Aug 24, 11:06 PM
identifiedWe are continuing to work on a fix for this issue.
Aug 24, 09:34 PM
identified🛠 We have identified an issue preventing people from broadcasting on Twitch. We're currently working to resolve this issue.

Identified Web Issues

major
Aug 24, 05:36 PMAug 24, 06:09 PMresolved
Aug 24, 06:09 PM
resolved🛠 We have resolved all known issues causing the Twitch website to fail to load for some users.
Aug 24, 05:55 PM
monitoringA fix has been implemented and we are monitoring the results.
Aug 24, 05:36 PM
identified🛠 We have identified an issue causing Twitch to fail to load in some cases.

July 2022

Identified Purchases Issues

major
Jul 16, 03:49 PMJul 16, 04:26 PMresolved
Jul 16, 04:26 PM
resolved🛠 We have resolved all known issues causing people to be unable to make purchases.
Jul 16, 03:49 PM
identified🛠 We have identified an issue causing some users to be unable to make purchases. We're currently working to resolve this issue.

May 2022

Identified Chat Issues

minor
May 20, 08:42 PMMay 20, 09:28 PMresolved
May 20, 09:28 PM
resolvedThis incident has been resolved.
May 20, 08:42 PM
identified🛠 We have identified an issue causing chat to not work for some users. We're currently working to resolve this issue.

Identified Checkout Issues

critical
May 18, 09:49 PMMay 18, 10:44 PMresolved
May 18, 10:44 PM
resolved🛠 We have resolved all known issues causing some users to be unable to checkout.
May 18, 10:30 PM
monitoringA fix has been implemented and we are monitoring the results.
May 18, 09:49 PM
identified🛠 We have identified an issue causing some users to be unable to checkout. We're currently working to resolve this issue.

April 2022

Identified Login Issues

major
Apr 10, 10:48 AMApr 10, 11:30 AMresolved
Apr 10, 11:30 AM
resolved🛠 We have resolved all known login issues.
Apr 10, 11:20 AM
monitoringA fix has been implemented and we are monitoring the results.
Apr 10, 10:48 AM
investigating🛠 We have identified an issue where some users are unable to log in. We're currently working to resolve this issue.

March 2022

Identified Web Issues

none
Mar 21, 11:15 AMMar 21, 12:01 PMresolved
Mar 21, 12:01 PM
resolvedThis incident has been resolved.
Mar 21, 11:15 AM
identified🛠 We have identified an issue causing Twitch to fail to load in some cases.

February 2022

Purchases Issues - Resolved

none
Feb 11, 10:00 PMFeb 11, 10:00 PMresolved
Feb 11, 11:49 PM
resolved🛠 We have resolved all known issues causing people to be unable to make purchases.

Identified Purchases Issues

minor
Feb 2, 07:14 AMFeb 2, 08:02 AMresolved
Feb 2, 08:02 AM
resolvedThis incident has been resolved.
Feb 2, 07:14 AM
identified🛠 We have identified an issue causing some users to be unable to make purchases. We're currently working to resolve this issue.

January 2022

Identified Purchases Issues

none
Jan 25, 08:01 PMJan 25, 10:30 PMresolved
Jan 25, 10:30 PM
resolvedThis incident has been resolved.
Jan 25, 10:29 PM
monitoringWe are continuing to monitor for any further issues.
Jan 25, 09:30 PM
monitoringA fix has been implemented and we are monitoring the results.
+1 more updates

Identified Subscriptions Issue

none
Jan 20, 06:40 PMJan 20, 07:15 PMresolved
Jan 20, 07:15 PM
resolvedThis incident has been resolved.
Jan 20, 06:56 PM
monitoringA fix has been implemented and we are monitoring the results.
Jan 20, 06:40 PM
identified🛠 We have identified an issue with Subscriptions. We're currently working to resolve this issue.

December 2021

Identified Web Issues

major
Dec 15, 04:11 PMDec 15, 05:04 PMresolved
Dec 15, 05:04 PM
resolvedThis incident has been resolved.
Dec 15, 04:45 PM
monitoringA fix has been implemented and we are monitoring the results.
Dec 15, 04:13 PM
identifiedWe are continuing to work on a fix for this issue.
+1 more updates

September 2021

Purchases Issues - Identified

minor
Sep 23, 08:06 AMSep 23, 10:19 AMresolved
Sep 23, 10:19 AM
resolvedThis incident has been resolved.
Sep 23, 09:27 AM
monitoring🛠 We have identified an issue causing some users to be unable to checkout. We're currently working to resolve this issue.
Sep 23, 08:06 AM
identified🛠 We have identified an issue causing some users to be unable to make purchases. We're currently working to resolve this issue.

August 2021

Identified Web Issues

minor
Aug 31, 06:32 PMSep 1, 07:09 AMresolved
Sep 1, 07:09 AM
resolvedThis incident has been resolved.
Sep 1, 12:49 AM
monitoringWe are continuing to monitor for any further issues.
Aug 31, 11:17 PM
monitoringA fix has been implemented and we are monitoring the results.
+2 more updates

Identified Video Issues

minor
Aug 25, 10:35 PMAug 26, 11:30 PMresolved
Aug 27, 05:43 AM
resolvedThis incident has been resolved.
Aug 27, 05:40 AM
investigatingWe have resolved all known issues.
Aug 25, 10:35 PM
investigatingWe are aware of an issue with Twitch video. We're currently investigating and working to resolve the issue.

Identified Login Issues

none
Aug 21, 08:11 PMAug 26, 08:36 PMresolved
Aug 26, 08:36 PM
resolved🛠 We have resolved all known login issues.
Aug 21, 08:11 PM
investigating🔎 We are aware of an issue causing some Twitch users to be unable to log in using Facebook. We're currently working to resolve this issue.

Subscriptions Issues - Identified

major
Aug 6, 09:26 PMAug 6, 09:57 PMresolved
Aug 6, 09:57 PM
resolvedThis incident has been resolved.
Aug 6, 09:40 PM
monitoringA fix has been implemented and we are monitoring the results.
Aug 6, 09:26 PM
investigating🛠 We have identified an issue with Subscriptions. We're currently working to resolve this issue.

July 2021

Identified Video (Broadcasting) Issues

none
Jul 2, 07:09 PMJul 2, 08:09 PMresolved
Jul 2, 08:09 PM
resolvedThis incident has been resolved.
Jul 2, 07:45 PM
monitoringA fix has been implemented and we are monitoring the results.
Jul 2, 07:33 PM
investigatingWe are currently investigating this issue.
+2 more updates

June 2021

Identified Video (Watching) Issues

minor
Jun 25, 06:25 PMJun 25, 07:42 PMresolved
Jun 25, 07:42 PM
resolved🛠 We've resolved all known issues of streams not playing across Twitch.
Jun 25, 06:53 PM
identified🛠 We have identified an issue preventing people from watching streams on Twitch. We're currently working to resolve this issue.

Identified Video (Broadcasting) Issues

major
Jun 10, 01:33 AMJun 10, 02:32 AMresolved
Jun 10, 02:32 AM
resolved🛠 We've resolved all known issues of broadcasters not being able to stream on Twitch.
Jun 10, 01:33 AM
identified🛠 We have identified an issue preventing people from broadcasting on Twitch. We're currently working to resolve this issue.

Get Twitch API Outage Alerts

Be the first to know when Twitch API go down.