Mailgun Outage History
50 incidents reported. Data sourced from the official Mailgun status page.
50
Total Incidents
13
Major/Critical
28
Minor
50
Resolved
November 2025
Delayed Logs in EU Region
minorNov 29, 08:38 AM→Nov 29, 09:56 AMresolved
Nov 29, 09:56 AM
resolved — This incident has been resolved.
Nov 29, 09:02 AM
identified — Logs are currently experiencing delays of 20 minutes in Mailgun's EU region. Outbound processing, inbound processing, and webhook delivery are operating normally.
Nov 29, 08:38 AM
identified — Logs are currently experiencing delays of 15 minutes in Mailgun's EU region. Outbound processing, inbound processing, and webhook delivery are operating normally.
Delayed Logs in EU Region
minorNov 28, 08:28 AM→Nov 28, 07:14 PMresolved
Nov 28, 07:14 PM
resolved — All systems are operating normally.
Nov 28, 06:54 PM
monitoring — Events are processing normally without delay. We will continue to monitor the performance of the logging system.
Nov 28, 06:26 PM
monitoring — Logs are currently delayed by 20 minutes due to elevated sending volumes. Outbound sending, inbound messages, and webhooks are not impacted.
+26 more updates
Delayed Logs in US Region
minorNov 28, 04:30 PM→Nov 28, 05:56 PMresolved
Nov 28, 05:56 PM
resolved — Events are processing normally.
Nov 28, 05:19 PM
monitoring — Events are processing normally, we continue to monitor as we see elevated send volumes.
Nov 28, 04:30 PM
identified — Logs are currently experiencing delays of 15 minutes in Mailgun's US region. Outbound processing, inbound processing, and webhook delivery are operating normally.
Delayed Logs in EU Region
minorNov 27, 08:46 AM→Nov 27, 11:07 AMresolved
Nov 27, 11:07 AM
resolved — This incident has been resolved.
Nov 27, 10:49 AM
monitoring — We continue to monitor while the system processes delayed events.
Nov 27, 10:21 AM
monitoring — A fix has been implemented and we are monitoring the results. The system continues to work through the delayed logging events backlog.
+4 more updates
Elevated inbound recipient rejected
noneNov 13, 10:30 AM→Nov 13, 10:30 AMresolved
Nov 18, 01:31 PM
resolved — On November 13th, Mailgun incorrectly rejected a subset of inbound emails with a 550 "recipient rejected" error. Senders received bounce notifications even though delivery should have succeeded.
Affe...
October 2025
Delayed Message Processing in US
minorOct 24, 02:14 PM→Oct 24, 03:58 PMresolved
Oct 24, 03:58 PM
resolved — This incident has been resolved.
Oct 24, 03:40 PM
monitoring — Operations are back to normal and queues are cleared. We'll continue to monitor.
Oct 24, 02:47 PM
monitoring — Queues are being worked through, we continue to monitor resolution.
+1 more updates
US Email Ingest Errors
minorOct 8, 01:00 PM→Oct 8, 01:00 PMresolved
Oct 8, 03:00 PM
resolved — Between 12:55 UTC and 13:07 UTC, customers may have experienced email sending failures in the US region. A deployment of new code caused our sending pipeline to temporarily reject some email submissio...
September 2025
Login issues with Mailgun Application
minorSep 30, 10:57 AM→Sep 30, 12:13 PMresolved
Sep 30, 12:13 PM
resolved — This incident has been resolved.
Sep 30, 11:46 AM
monitoring — We are continuing to monitor for any further issues.
Sep 30, 11:46 AM
monitoring — A fix has been implemented and we are monitoring the results.
+2 more updates
Sending errors in US
majorSep 12, 10:07 AM→Sep 12, 03:21 PMresolved
Sep 12, 03:21 PM
resolved — All systems are operating normally at this time. Our engineers continue to monitor our systems for any recurrence or new issues.
Sep 12, 02:48 PM
monitoring — Systems have normalized, we are continuing to monitor for any issues.
Sep 12, 01:57 PM
monitoring — A fix has been implemented and we are monitoring the results.
+7 more updates
Message Delays in US Region
minorSep 12, 06:26 AM→Sep 12, 08:25 AMresolved
Sep 12, 08:25 AM
resolved — This incident has been resolved.
Sep 12, 07:29 AM
monitoring — A fix has been implemented and we are monitoring the results.
Sep 12, 06:26 AM
investigating — We are currently investigating this issue.
Email Validation 500s
majorSep 11, 10:56 PM→Sep 12, 02:19 AMresolved
Sep 12, 02:19 AM
resolved — This incident has been resolved.
Sep 12, 02:07 AM
monitoring — We are continuing to monitor for any further issues.
Sep 12, 02:07 AM
monitoring — A fix has been implemented and we are monitoring the results.
+3 more updates
EU email delivery latency
minorSep 1, 04:23 PM→Sep 1, 05:11 PMresolved
Sep 1, 05:11 PM
resolved — This incident has been resolved.
Sep 1, 04:53 PM
monitoring — Queues are being worked through. Normal email delivery times will resume shortly. In addition to delayed email delivery, these other parts of our system saw increased processing time as well: inbound ...
Sep 1, 04:38 PM
monitoring — A fix has been implemented and we are monitoring the results.
+4 more updates
August 2025
US email delivery latency
minorAug 20, 04:20 PM→Aug 20, 05:14 PMresolved
Aug 20, 05:14 PM
resolved — This incident has been resolved.
Aug 20, 04:27 PM
monitoring — Services are fully operational.
Aug 20, 04:20 PM
monitoring — Email's from our us-east region may have experienced longer delivery time between 16:00 UTC and 16:20 UTC. The issue is resolved and we are monitoring.
July 2025
Partial Delay in Event Processing
minorJul 29, 03:37 PM→Jul 29, 06:17 PMresolved
Jul 29, 06:17 PM
resolved — This incident has been resolved.
Jul 29, 05:54 PM
monitoring — We are continuing to monitor the system as delays resolve
Jul 29, 03:45 PM
monitoring — A fix has been implemented and we are monitoring the results.
+1 more updates
HTTPS Tracking Certificate Creation / Renewal blocked by Let's Encrypt Outage
minorJul 21, 11:56 PM→Jul 22, 11:33 AMresolved
Jul 22, 11:33 AM
resolved — This incident has been resolved.
Jul 22, 05:22 AM
monitoring — The current status of Let's Encrypt infrastucture is "[Identified] We have deployed mitigations for the failure of our internal DNS servers. Issuance of certificates is now succeeding, though we are s...
Jul 21, 11:56 PM
identified — Let's Encrypt, the certificate issuer used for creating certificates on customer tracking domains is experiencing an outage (https://letsencrypt.status.io/). Attempting to generate or regenerate a tra...
May 2025
Degraded performance
minorMay 19, 09:27 PM→May 19, 10:28 PMresolved
May 19, 10:28 PM
resolved — This incident has been resolved.
May 19, 09:48 PM
monitoring — A fix has been implemented and we are monitoring the results.
May 19, 09:33 PM
identified — We have identified an issue with one of our datastores and are attempting to implement a fix.
+1 more updates
Intermittent API Errors
criticalMay 14, 06:38 PM→May 14, 10:18 PMresolved
May 14, 10:18 PM
resolved — This incident has been resolved.
May 14, 10:03 PM
monitoring — A fix has been deployed and we are monitoring.
May 14, 09:32 PM
identified — We identified a routing issue in our internal service mesh. We are attempting to roll out a fix.
+5 more updates
March 2025
Errors connecting to smtp.eu.mailgun.org
majorMar 17, 09:20 AM→Mar 17, 07:44 PMresolved
Mar 17, 07:44 PM
resolved — This incident has been resolved.
Mar 17, 06:43 PM
monitoring — We are continuing to monitor for any further issues.
Mar 17, 03:02 PM
monitoring — A mitigation has been put in place and SMTP / Inbound email processing in our EU region is back to full working behavior.
+5 more updates
February 2025
Intermittent Log and Event API Errors
minorFeb 10, 05:23 PM→Feb 10, 07:22 PMresolved
Feb 10, 07:22 PM
resolved — This incident has been resolved.
Feb 10, 07:20 PM
monitoring — A fix has been implemented and we are monitoring the results.
Feb 10, 07:19 PM
monitoring — A fix has been implemented and we are monitoring the results.
+1 more updates
November 2024
Login Errors
minorNov 14, 11:58 PM→Nov 15, 12:28 AMresolved
Nov 15, 12:28 AM
resolved — This incident has been resolved.
Nov 15, 12:26 AM
investigating — Our team has resolved the login issue.
Nov 14, 11:58 PM
investigating — Our team is investigating reports of Login issues for a subset of administrative accounts
October 2024
Europe - Email Delivery Latency
minorOct 17, 12:12 PM→Oct 17, 08:41 PMresolved
Oct 17, 08:41 PM
resolved — This incident has been resolved.
Oct 17, 08:02 PM
monitoring — A fix has been implemented and traffic is sending through these networks. We are monitoring the resolution.
Oct 17, 07:15 PM
identified — We are continuing to work with our network provider to bring this range online.
+5 more updates
September 2024
US Region(s): Elevated SMTP Connection Latency / Timeouts
minorSep 30, 08:47 PM→Oct 1, 12:29 AMresolved
Oct 1, 12:29 AM
resolved — This incident has been resolved.
Sep 30, 11:38 PM
monitoring — A fix has been implemented and we are monitoring the results.
Sep 30, 08:47 PM
investigating — We are currently experiencing elevated timeouts when sending email via SMTP in US regions. Investigation is underway.
August 2024
US Email Delivery Issue
noneAug 20, 07:00 PM→Aug 20, 07:00 PMresolved
Aug 21, 12:03 PM
resolved — On August 20th, 2024, between 18:45 - 22:45 UTC, emails submitted to our US region experienced a small chance of delivery failure. Please review your email Events for "602 Too old message" errors to i...
Intermittent errors for login.mailgun.com and app.mailgun.com
majorAug 17, 05:35 PM→Aug 17, 05:57 PMresolved
Aug 17, 05:57 PM
resolved — This incident has been resolved.
Aug 17, 05:55 PM
monitoring — We are continuing to monitor for any further issues.
Aug 17, 05:52 PM
monitoring — A fix has been implemented and we are monitoring the results.
+2 more updates
July 2024
Delayed Logs in EU Region
minorJul 19, 11:03 AM→Jul 19, 04:24 PMresolved
Jul 19, 04:24 PM
resolved — This incident has been resolved.
Jul 19, 02:35 PM
monitoring — Data is continuing to be backfilled. We are monitoring the process.
Jul 19, 01:22 PM
monitoring — We are monitoring the backfill process for log data.
+3 more updates
SSL Connection Errors for SMTP (eu.mailgun.org)
majorJul 11, 03:46 PM→Jul 11, 03:59 PMresolved
Jul 11, 03:59 PM
resolved — This incident has been resolved.
Jul 11, 03:54 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jul 11, 03:46 PM
identified — The issue has been identified and a fix is being implemented.
Customer Portal Intermittently not Loading
majorJul 1, 04:57 PM→Jul 1, 05:18 PMresolved
Jul 1, 05:18 PM
resolved — This incident has been resolved.
Jul 1, 05:08 PM
monitoring — We have identified the issue and are monitoring the resolution.
Jul 1, 04:57 PM
investigating — The customer portal is loading intermittently, we are investigating the issue at this time.
May 2024
Login & Sending Issues
criticalMay 31, 08:10 AM→May 31, 10:22 AMresolved
May 31, 10:22 AM
resolved — This incident has been resolved.
May 31, 08:50 AM
monitoring — We are continuing to monitor for any further issues.
May 31, 08:30 AM
monitoring — A fix has been implemented and we are monitoring the results.
+2 more updates
Login & Sending Issues
noneMay 27, 01:29 PM→May 27, 06:28 PMresolved
May 27, 06:28 PM
resolved — This incident has been resolved.
May 27, 06:28 PM
monitoring — We are continuing to monitor for any further issues.
May 27, 06:05 PM
monitoring — We are continuing to monitor for any further issues.
+10 more updates
Login issues
majorMay 2, 06:41 AM→May 2, 08:01 AMresolved
May 2, 08:01 AM
resolved — This incident has been resolved.
May 2, 07:50 AM
monitoring — A fix has been implemented and we are monitoring the results.
May 2, 07:18 AM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
March 2024
US Logs & Events API Issues
minorMar 27, 11:52 AM→Mar 28, 03:37 AMresolved
Mar 28, 03:37 AM
resolved — The data back fill process will complete shortly.
Mar 27, 09:27 PM
monitoring — The work on restoring the missing data from 00:00 -> 1:40 UTC continues. We are continuing to monitor the back fill process.
Mar 27, 07:04 PM
monitoring — The work on restoring the missing data from 00:00 -> 1:40 UTC is well underway. We continue to monitor the backfill process.
+5 more updates
February 2024
Intermittent errors from stats endpoints
majorFeb 22, 09:02 PM→Feb 22, 09:50 PMresolved
Feb 22, 09:50 PM
resolved — This incident has been resolved.
Feb 22, 09:14 PM
monitoring — A fix has been implemented and we are monitoring the results.
Feb 22, 09:02 PM
identified — The issue has been identified and a fix is being implemented.
Intermittent Connection Timeouts SMTP and HTTP(s) in US.
minorFeb 22, 04:36 PM→Feb 22, 06:34 PMresolved
Feb 22, 06:34 PM
resolved — This incident has been resolved.
Feb 22, 05:41 PM
monitoring — A fix has been implemented and we are monitoring the results.
Feb 22, 04:36 PM
identified — We are continuing to work on a fix for this issue.
+1 more updates
Intermittent errors from stats endpoints
majorFeb 15, 08:55 PM→Feb 15, 09:44 PMresolved
Feb 15, 09:44 PM
resolved — This incident has been resolved.
Feb 15, 09:25 PM
monitoring — A fix has been implemented and we are monitoring the results.
Feb 15, 08:55 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Login Issues to Mailgun and intermittent connection issues to api.mailgun.net
majorFeb 12, 09:06 AM→Feb 13, 04:01 PMresolved
Feb 13, 04:01 PM
resolved — This incident has been resolved.
Feb 13, 01:40 PM
monitoring — We are continuing to monitor our systems. All impacts of this attack have been mitigated at this time.
Feb 13, 01:50 AM
monitoring — A mitigation has been put in place to restore the functionality of our login page. We are continuing to monitor the DDOS attack.
+6 more updates
Log events may be delayed for some customers.
minorFeb 8, 08:40 PM→Feb 9, 12:31 AMresolved
Feb 9, 12:31 AM
resolved — This incident has been resolved.
Feb 8, 11:27 PM
monitoring — Delay continues to decrease, we are monitoring the recovery at this time.
Feb 8, 10:24 PM
monitoring — We are monitoring our system as the delay resolves.
+2 more updates
Intermittent connection issues to api.eu.mailgun.net
majorFeb 6, 05:16 PM→Feb 6, 05:52 PMresolved
Feb 6, 05:52 PM
resolved — This incident has been resolved.
Feb 6, 05:37 PM
monitoring — A fix has been implemented and we are monitoring the results.
Feb 6, 05:16 PM
investigating — We are currently investigating this issue.
November 2023
Intermittent Errors Mailgun Control Panel
noneNov 21, 06:50 PM→Nov 21, 07:31 PMresolved
Nov 21, 07:31 PM
resolved — This incident has been resolved.
Nov 21, 07:09 PM
monitoring — A fix has been implemented and we are monitoring the results.
Nov 21, 07:03 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
EU message delivery failures
minorNov 1, 12:49 AM→Nov 1, 02:49 AMresolved
Nov 1, 02:49 AM
resolved — This incident has been resolved.
Nov 1, 02:31 AM
monitoring — We are continuing to monitor for any further issues.
Nov 1, 02:31 AM
monitoring — The issue has been addressed. Monitoring continues.
+2 more updates
October 2023
Control Panel Intermittently Unavailable
noneOct 19, 05:09 PM→Oct 19, 06:12 PMresolved
Oct 19, 06:12 PM
resolved — This incident has been resolved.
Oct 19, 05:51 PM
monitoring — A fix has been implemented and we are monitoring the results.
Oct 19, 05:39 PM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
HTTPs Tracking Outage
noneOct 7, 05:30 AM→Oct 7, 05:30 AMresolved
Oct 9, 01:54 PM
resolved — Tracking events for domains using HTTPs tracking were not processed due to an outage.
Delayed Sending in US Region
noneOct 3, 05:16 PM→Oct 4, 02:30 AMresolved
Oct 3, 05:16 PM
resolved — This incident has been resolved.
September 2023
Sending Delays in US region
noneSep 5, 12:16 PM→Sep 5, 01:13 PMresolved
Sep 5, 01:13 PM
resolved — This incident has been resolved.
Sep 5, 01:13 PM
monitoring — We are continuing to monitor for any further issues.
Sep 5, 01:03 PM
monitoring — A fix has been implemented and we are monitoring the results.
+1 more updates
August 2023
Increased errors on /message API
noneAug 29, 04:08 PM→Aug 29, 04:35 PMresolved
Aug 29, 04:35 PM
resolved — This incident has been resolved.
Aug 29, 04:08 PM
monitoring — You may have experienced elevated 404s on our message endpoint in the US region. The issue has been identified and a fix has been put in place.
July 2023
Delays in EU transactional email delivery time
minorJul 27, 03:32 PM→Jul 27, 04:43 PMresolved
Jul 27, 04:43 PM
resolved — This incident has been resolved.
Jul 27, 04:07 PM
monitoring — Delivery time for EU transactional emails is back to normal. We continue to monitor.
Jul 27, 03:32 PM
investigating — We are currently experiencing delays delivering transactional emails in our EU region. Investigation is ongoing.
EU region inbound route processing delays
minorJul 25, 05:02 PM→Jul 25, 06:53 PMresolved
Jul 25, 06:53 PM
resolved — This incident has been resolved.
Jul 25, 06:41 PM
monitoring — A fix has been implemented and we are monitoring the results.
Jul 25, 06:28 PM
investigating — We are continuing to investigate the issue.
+1 more updates
June 2023
Intermittent Login Issues
minorJun 1, 06:22 PM→Jun 2, 12:48 AMresolved
Jun 2, 12:48 AM
resolved — This incident has been resolved.
Jun 1, 10:20 PM
monitoring — A fix has been implemented. We continue to monitor.
Jun 1, 08:03 PM
identified — We continue to investigate a fix.
+1 more updates
May 2023
Intermittent Login Issues
minorMay 31, 03:13 PM→May 31, 04:44 PMresolved
May 31, 04:44 PM
resolved — This incident has been resolved.
May 31, 03:58 PM
monitoring — A fix has been implemented and we are monitoring the resolution.
May 31, 03:13 PM
investigating — We are currently investigating intermittent issues logging into the Mailgun control panel.
Intermittent Login Errors
minorMay 3, 08:51 PM→May 3, 10:17 PMresolved
May 3, 10:17 PM
resolved — This incident has been resolved.
May 3, 09:20 PM
identified — We have identified the cause of intermittent errors when logging into or navigating the Control Panel and are working on a fix.
May 3, 08:51 PM
investigating — We are currently investigating intermittent errors when logging into or navigating the Control Panel.
February 2023
Intermittent connection issues
minorFeb 21, 03:31 PM→Feb 28, 05:20 PMresolved
Feb 28, 05:20 PM
resolved — This incident has been resolved.
Feb 27, 06:07 PM
monitoring — We continue to closely monitor traffic and are prepared to make additional proactive and reactive infrastructure changes as required.
Feb 25, 02:38 AM
monitoring — We have completed a series of successful infrastructure changes and will monitor traffic closely over the weekend. Unless there is another major development, our next update will be on Monday.
+15 more updates
Related Incident Histories
Get Mailgun Outage Alerts
Be the first to know when Mailgun go down.