PlanetScale Outage History
25 incidents reported. Data sourced from the official PlanetScale status page.
25
Total Incidents
14
Major/Critical
10
Minor
25
Resolved
July 2026
Insights metrics underreporting
majorJul 24, 02:41 PM→Jul 24, 05:42 PMresolved
Jul 24, 09:13 PM
resolved — The incident has been resolved.
Jul 24, 05:04 PM
monitoring — Mitigations are in place and we're seeing signs of recovery. We continue to monitor the health of the system.
Jul 24, 02:41 PM
identified — Insights metrics are underreporting for Postgres and Vitess databases. Database traffic and connectivity are unaffected. We are actively investigating the issue and are deploying mitigations.
Insights metrics underreporting
minorJul 20, 06:29 PM→Jul 21, 03:18 PMresolved
Jul 21, 03:18 PM
resolved — Query Insights functionality is restored on all Postgres development branches.
Jul 20, 10:06 PM
monitoring — Query Insights is gradually recovering across all Postgres development branches.
Jul 20, 09:32 PM
identified — Query Insights is recovered across all branches except for Postgres development branches, where recovery is happening gradually. We are working to accelerate recovery of Query Insights Postgres develo...
+5 more updates
Connectivity issues in us-east-1
majorJul 18, 08:32 PM→Jul 18, 09:05 PMresolved
Jul 18, 09:05 PM
resolved — Connection issues have been resolved. If you experience any further issues, please contact our support team.
Jul 18, 08:49 PM
monitoring — We remediated the issue, and clients can now connect to their database branches in us-east-1 normally. We will continue monitoring the situation.
Jul 18, 08:32 PM
investigating — We are observing connectivity issues on Postgres in the us-east-1 region. We are remediating.
API and dashboard errors
majorJul 17, 04:41 PM→Jul 17, 05:09 PMresolved
Jul 17, 05:09 PM
resolved — API and dashboard service is restored.
Jul 17, 04:59 PM
monitoring — We have increased the memory available to the API and are monitoring the performance and stability of the API and dashboard to confirm service is restored.
Jul 17, 04:49 PM
identified — We have identified the cause of the errors - a pattern of requests causing the application to run out of memory and crash - and are working to better handle this traffic pattern now.
+1 more updates
Single Sign On (SSO) unavailable
minorJul 16, 09:30 AM→Jul 16, 10:52 AMresolved
Jul 16, 10:52 AM
resolved — The issue is resolved. SSO is working fine again.
Jul 16, 09:30 AM
investigating — SSO login to the PlanetScale website and API is unavailable. We are investigating. Database operations are unaffected.
Development branches with MySQL Vectors not serving
minorJul 6, 07:18 PM→Jul 6, 09:45 PMresolved
Jul 6, 09:45 PM
resolved — All impacted branches are recovered.
PlanetScale upgraded development Vitess branches with Vectors enabled from MySQL 8.0.x to 8.4.x. PlanetScale runs an internal fork containing support for PlanetSc...
Jul 6, 08:38 PM
monitoring — Branches are recovering and we are monitoring the situation.
Jul 6, 07:23 PM
identified — We have identified the issue and are rolling impacted development branches from 8.4 back to 8.0.
+1 more updates
May 2026
There is an incident in PlanetScale GCP us-central1 region impacting Postgres database availability. We are actively investigating and will update as soon as we have more information.
majorMay 14, 08:30 PM→May 14, 09:03 PMresolved
May 14, 09:03 PM
resolved — The changes we applied are effectively preventing further unexpected restarts to the high availability component shared by Postgres clusters. We have not seen further restarts to this component nor un...
May 14, 08:51 PM
monitoring — We applied changes to prevent unexpected restarts of the high availability component shared by Postgres clusters. We have not seen further restarts of this component nor unplanned Postgres failovers s...
May 14, 08:42 PM
identified — We have identified the likely cause of unexpected restarts to the high availability component used by Postgres clusters, and are applying changes to prevent recurrences.
+1 more updates
Database operations degraded in eu-west-2
minorMay 13, 05:17 PM→May 13, 06:04 PMresolved
May 13, 06:04 PM
resolved — PlanetScale has remediated the issue and it is fully resolved.
May 13, 05:32 PM
monitoring — We've identified the issue and have taken steps to mitigate it. Database operations will successfully complete again. We continue to monitor the situation.
May 13, 05:17 PM
investigating — We're aware of a degradation in eu-west-2 where database operations such as resizes, branch creations or parameter changes may not complete. We're investigating the problem.
AWS use1-az4 thermal event
noneMay 8, 02:22 AM→May 8, 07:22 PMresolved
May 8, 07:22 PM
resolved — PlanetScale is not observing any database impact resulting from the AWS use1-az4 thermal event. Please contact support if you have any questions or notice any disruption.
May 8, 02:22 AM
monitoring — PlanetScale is aware of the AWS use1-az4 thermal event. We expect databases to be unaffected. Please contact support if you have any questions or notice any disruption.
April 2026
Errors with database webhooks
minorApr 8, 12:34 AM→Apr 8, 12:49 AMresolved
Apr 8, 12:49 AM
resolved — The errors have been resolved.
Apr 8, 12:42 AM
monitoring — We've made a fix and are seeing webhooks trigger properly again.
Apr 8, 12:34 AM
investigating — We're investigating an issue with webhook deliveries failing.
Currently experiencing issues with creating/updating/deleting Vitess credentials
minorApr 2, 10:37 PM→Apr 2, 10:52 PMresolved
Apr 2, 10:52 PM
resolved — Some percentage of new credential creates, updates, and deletes errored or were very slow for approx 35 minutes.
Apr 2, 10:46 PM
monitoring — We have applied a fix and see recovery.
Apr 2, 10:37 PM
investigating — All existing credentials still work and will continue to work.
We are investigating an issue affecting only modifying or creating new ones.
March 2026
us-east-1 connection errors
majorMar 11, 01:04 PM→Mar 11, 01:19 PMresolved
Mar 11, 02:52 PM
resolved — This incident has been resolved.
Mar 11, 02:17 PM
monitoring — We're continuing to monitor. We've updated the status history to reflect the time periods where customers experienced connection issues.
Mar 11, 01:19 PM
resolved — At **12:51 PM UTC** and **1:38 PM UTC** some Vitess databases in us-east-1 were impacted by connection errors for approximately 5 minutes due to an issue in our edge network. We resolved the issue and...
+1 more updates
February 2026
Vitess branch creation unavailable
majorFeb 24, 10:26 AM→Feb 24, 12:00 PMresolved
Feb 24, 12:00 PM
resolved — Vitess branch creation is available once again.
Feb 24, 11:00 AM
investigating — We're rolling out a mitigation now that will allow Vitess branch creation to succeed while we continue to investigate. No database operations or anything about Postgres database creation are impacted....
Feb 24, 10:26 AM
investigating — New Vitess databases are being accepted by the PlanetScale API but we are unable to provision the infrastructure to serve them. We've confirmed this impact and are investigating the cause. We will pro...
Vitess database availability issues in GCP northamerica-northeast1
majorFeb 18, 08:23 PM→Feb 18, 09:06 PMresolved
Feb 18, 09:06 PM
resolved — Problem has been resolved. We saw three nodes fail across three availability zones simultaneously. Impacting databases hosted on those nodes.
All databases have been moved to healthy nodes and we're ...
Feb 18, 08:43 PM
monitoring — Impacted databases are recovering, we're continuing to monitor.
Feb 18, 08:34 PM
identified — We're working on a fix for the impacted databases.
+1 more updates
January 2026
Query insights outage
criticalJan 31, 09:38 AM→Jan 31, 11:58 AMresolved
Jan 31, 11:58 AM
resolved — Query Insights is fully operational.
Jan 31, 11:06 AM
monitoring — Insights service is restored and we are blasting through the backlog of data.
Jan 31, 10:08 AM
identified — There is an incident with a downstream provider.
[https://status.clickhouse.com/incidents/01KG9R4QYASZW9VXHG3S2YD4WD](https://status.clickhouse.com/incidents/01KG9R4QYASZW9VXHG3S2YD4WD "https://stat...
+1 more updates
API availability issues
majorJan 9, 01:29 AM→Jan 9, 01:46 AMresolved
Jan 9, 01:46 AM
resolved — The issue has been resolved.
Jan 9, 01:38 AM
monitoring — A fix has been applied, and we are monitoring recovery.
Jan 9, 01:29 AM
investigating — We are investigating internal errors on some API endpoints. Database connectivity is unaffected.
Insights ingestion delayed
minorJan 8, 04:30 PM→Jan 8, 06:14 PMresolved
Jan 8, 06:14 PM
resolved — Insights data ingestion encountered an error due to an unexpected data format. The issue was identified and fixed, and ingestion resumed.
Jan 8, 04:30 PM
identified — Insights data ingestion is delayed. This underlying issue has identified and the Insights data backlog is being processed
Errors with branch creation for GCP databases
majorJan 6, 04:27 PM→Jan 6, 05:41 PMresolved
Jan 6, 05:41 PM
resolved — This incident is resolved.
Jan 6, 05:37 PM
monitoring — We've deployed a fix and are seeing error rates resolve.
Jan 6, 05:12 PM
identified — We're continuing to work on a fix and will share an update once it has been deployed.
+1 more updates
November 2025
API and dashboard: 500 errors
majorNov 17, 06:10 PM→Nov 13, 06:45 PMresolved
Nov 17, 06:10 PM
resolved — We've made a fix and the errors have resolved.
Nov 17, 06:10 PM
identified — The dashboard and API are currently returning 500 errors. We are rolling out a fix.
October 2025
Elevated error rates with Dashboard and API due to AWS us-east-1 outage
minorOct 20, 09:53 AM→Oct 20, 09:36 AMresolved
Oct 20, 08:48 PM
resolved — PlanetScale is continuing to monitor the condition of AWS us-east-1. At this point we do not see any further impact, and have re-enabled database and branch creation in the region.
Oct 20, 08:08 PM
monitoring — PlanetScale is continuing to monitor the condition of AWS us-east-1. We have seen networking conditions and compute availability in us-east-1 continue to improve. Out of caution, database and branch c...
Oct 20, 06:56 PM
monitoring — PlanetScale is continuing to monitor the condition of AWS us-east-1. At this time database and branch creation continues to be disabled, and we are seeing some degraded network performance between com...
+7 more updates
Delays in Datadog metric publishing
minorOct 20, 04:09 PM→Oct 20, 04:36 PMresolved
Oct 20, 04:36 PM
resolved — Datadog metrics are back up-to-date.
Oct 20, 04:09 PM
monitoring — During the ongoing incident, some branches are seeing delays in metrics via the Datadog integration.
some databases stuck in reparenting
majorOct 15, 06:29 PM→Oct 16, 01:52 AMresolved
Oct 16, 01:52 AM
resolved — No further disruption is expected, please contact support with any further issues.
Oct 15, 08:31 PM
monitoring — All databases have recovered, but we are continuing to watch the situation closely.
Oct 15, 07:44 PM
monitoring — We are continuing to investigate
+3 more updates
SSO Authentication Errors
majorOct 7, 10:04 PM→Oct 7, 11:12 PMresolved
Oct 7, 11:12 PM
resolved — We've resolved the issue. SSO/SAML is working again.
Oct 7, 10:59 PM
investigating — We've identified a potential fix, testing, and the preparing to roll it out.
Oct 7, 10:31 PM
investigating — We are continuing to investigate. We've confirmed an issue with our SSO integration, but are still searching for a root cause.
+1 more updates
We are investigating reports of connection issues with us-east-1
minorOct 1, 03:10 PM→Oct 1, 03:15 PMresolved
Oct 1, 03:15 PM
resolved — All systems operating normally
Oct 1, 03:10 PM
investigating — We are investigating reports of connection issues with us-east-1
September 2025
Partial unavailability of an isolated set of clusters in us-east-1
majorSep 17, 02:06 PM→Sep 17, 02:41 PMresolved
Sep 17, 02:41 PM
resolved — All services operational.
Sep 17, 02:37 PM
monitoring — All clusters are online and serving traffic. We are monitoring out of caution before returning to green status.
Sep 17, 02:28 PM
monitoring — Most affected clusters are now online. The last few are coming up now.
+3 more updates
Related Incident Histories
Get PlanetScale Outage Alerts
Be the first to know when PlanetScale go down.