Cursor Outage History
50 incidents reported. Data sourced from the official Cursor status page.
50
Total Incidents
13
Major/Critical
37
Minor
50
Resolved
July 2026
Investigating service degradation
criticalJul 31, 07:50 PM→Jul 31, 09:10 PMresolved
Jul 31, 09:10 PM
resolved — This incident has been resolved. All services have returned to normal operation.
Jul 31, 08:56 PM
monitoring — Service is largely recovering. Some intermittent issues may remain as we finish restoring all systems. We are continuing to monitor.
Jul 31, 08:37 PM
monitoring — A fix has been implemented and we are monitoring for service restoration.
+3 more updates
Investigating service degradation — IDE
minorJul 30, 08:57 AM→Jul 30, 09:48 AMresolved
Jul 30, 09:48 AM
resolved — This incident has been resolved. Fable 5 and Opus 5 inference has returned to normal.
Jul 30, 09:38 AM
investigating — Opus 5 has recovered, we are still monitoring Fable 5. Some users may continue to see failed requests.
Jul 30, 08:57 AM
investigating — Investigating elevated errors for Fable 5 and Opus 5. Some users may see failed or retried requests. The provider has posted an incident and we are monitoring recovery. https://status.claude.com/
Investigating service degradation — IDE
minorJul 30, 06:16 AM→Jul 30, 06:33 AMresolved
Jul 30, 06:33 AM
resolved — This incident has been resolved. Claude inference has returned to normal.
Jul 30, 06:16 AM
investigating — Investigating elevated errors for Claude models Opus 4.8 and Opus 5. Some users may see failed or retried requests. The provider has posted an incident and we are monitoring recovery. https://status.c...
Elevated errors affecting Anthropic models
criticalJul 29, 07:58 PM→Jul 29, 11:15 PMresolved
Jul 29, 11:15 PM
resolved — Elevated errors affecting Anthropic models have been resolved. Service has been restored.
Jul 29, 09:49 PM
monitoring — Anthropic reports recovery across most Claude models and is continuing to fully resolve remaining elevated errors/latency. Please see https://status.claude.com/ for provider updates.
Jul 29, 08:38 PM
identified — Anthropic has identified an issue causing elevated errors across Claude models and is working on a fix. Please see https://status.claude.com/ for provider updates.
+1 more updates
Investigating Composer degradation
minorJul 29, 08:51 AM→Jul 29, 11:38 AMresolved
Jul 29, 11:38 AM
resolved — This incident has been resolved.
Jul 29, 09:57 AM
investigating — We are continuing to investigate this issue and will provide updates as more information becomes available.
Jul 29, 09:11 AM
investigating — We have resolved the service degradation with Grok 4.5 and are still investigating the degradation with Composer 2.5.
+1 more updates
Investigating service degradation — cursor.com, Automations, and Cloud Agents
minorJul 28, 06:19 PM→Jul 28, 06:24 PMresolved
Jul 28, 06:24 PM
resolved — This incident has been resolved.
Jul 28, 06:21 PM
monitoring — A fix has been implemented and we are monitoring for service restoration.
Jul 28, 06:19 PM
investigating — We are investigating a service degradation affecting cursor.com, Automations, and Cloud Agents.
Investigating service degradation — IDE
minorJul 28, 09:07 AM→Jul 28, 10:19 AMresolved
Jul 28, 10:19 AM
resolved — This incident has been resolved. GPT-5.4 was temporarily slightly degraded.
Jul 28, 09:07 AM
investigating — We are investigating a service degradation affecting GPT models in IDE.
Investigating Elevated Cursor Grok 4.5 Errors
minorJul 28, 12:34 AM→Jul 28, 12:45 AMresolved
Jul 28, 12:45 AM
resolved — This incident has been resolved.
Jul 28, 12:34 AM
investigating — We are investigating a service degradation affecting IDE & Cursor Grok 4.5
Investigating service degradation — Cloud Agents
minorJul 27, 05:09 PM→Jul 27, 07:39 PMresolved
Jul 27, 07:39 PM
resolved — This incident has been resolved.
Jul 27, 06:46 PM
monitoring — Automations are back to normal, and cloud agent start failures have subsided. We're monitoring closely to confirm full recovery.
Jul 27, 05:41 PM
identified — Some Cursor Automations may fail to start, and running Automations may be unable to post replies in Slack or open pull requests. We've identified the causes and fixes are rolling out.
+1 more updates
Investigating service degradation — IDE
minorJul 27, 11:41 AM→Jul 27, 11:41 AMresolved
Jul 27, 11:41 AM
resolved — This incident has been resolved.
Jul 27, 11:41 AM
investigating — We are investigating a service degradation affecting IDE, affected Opus 5. 04:19 - 04:22 AM PDT.
Investigating service degradation — IDE
minorJul 27, 09:48 AM→Jul 27, 09:50 AMresolved
Jul 27, 09:50 AM
resolved — This incident has been resolved.
Jul 27, 09:48 AM
investigating — We're Investigating an issue with requests to Opus causing degraded behaviour.
We're Investigating an issue with requests to Fable causing degraded behaviour
minorJul 23, 03:56 PM→Jul 23, 04:36 PMresolved
Jul 23, 04:36 PM
resolved — This incident has been resolved.
Jul 23, 03:56 PM
investigating — We are investigating a service degradation affecting Fable model requests
Anthropic elevated errors
minorJul 21, 03:52 PM→Jul 21, 06:53 PMresolved
Jul 21, 06:53 PM
resolved — This incident has been resolved.
Jul 21, 03:52 PM
investigating — We are investigating and observing a service degradation from several Anthropic models.
https://status.claude.com/
Investigating service degradation
minorJul 20, 02:54 AM→Jul 20, 12:23 PMresolved
Jul 20, 12:23 PM
resolved — This incident has been resolved.
Jul 20, 03:46 AM
monitoring — Service has stabilized across the affected surfaces, and we are actively monitoring performance.
Jul 20, 02:54 AM
investigating — We are investigating a service degradation. Affected agent surfaces: Composer, Cursor Grok 4.5, and Auto.
Investigating service degradation
minorJul 20, 02:00 AM→Jul 20, 02:19 AMresolved
Jul 20, 02:19 AM
resolved — This incident has been resolved.
Jul 20, 02:00 AM
investigating — We are investigating a service degradation of Cursor Grok 4.5, Cursor Grok 4.5 Fast, and Auto.
Investigating Anthropic degradation
minorJul 17, 07:17 AM→Jul 17, 12:27 PMresolved
Jul 17, 12:27 PM
resolved — This incident has been resolved.
Jul 17, 07:17 AM
identified — The root cause has been identified and a fix is being implemented.
Jul 17, 07:17 AM
investigating — Some Anthropic models are degraded. More information can be found here: https://status.claude.com/incidents/7gpjd8n56rlq
Investigating service degradation — Cloud Agents
minorJul 16, 10:33 PM→Jul 17, 12:15 AMresolved
Jul 17, 12:15 AM
resolved — This incident has been resolved.
Jul 16, 10:54 PM
investigating — We are continuing to investigate this issue. Cloud Agents may fail to run properly because of an upstream Github incident: https://www.githubstatus.com/incidents/gxycch3076xk
Jul 16, 10:33 PM
investigating — We are investigating a service degradation affecting Cloud Agents.
Authentication System degradation
majorJul 16, 08:32 AM→Jul 16, 10:46 AMresolved
Jul 16, 10:46 AM
resolved — This incident has been resolved.
Jul 16, 10:20 AM
monitoring — A fix has been implemented by our service provider, and we are monitoring for service restoration.
Jul 16, 08:32 AM
investigating — We are continuing to investigate a service degradation impacting authentication. If already logged in, please remain logged into Cursor to continue using Cursor services
Investigating Grok 4.5 degradation
criticalJul 16, 07:01 AM→Jul 16, 09:36 AMresolved
Jul 16, 09:36 AM
resolved — This incident has been resolved.
Jul 16, 09:34 AM
monitoring — A fix has been implemented and we are monitoring for service restoration.
Jul 16, 07:50 AM
investigating — Investigation is ongoing for degradation of Grok 4.5. Users should switch to Auto or try another model while we work toward a resolution.
+3 more updates
Investigating GPT-5.6 Sol degradation
minorJul 16, 05:31 AM→Jul 16, 06:15 AMresolved
Jul 16, 06:15 AM
resolved — This has been resolved.
Jul 16, 05:31 AM
investigating — GPT-5.6 Sol is degraded. The model provider is investigating.
Investigating service degradation
majorJul 15, 08:52 AM→Jul 15, 11:32 AMresolved
Jul 15, 11:32 AM
resolved — This incident has been resolved.
Jul 15, 10:58 AM
monitoring — A fix has been implemented and we are monitoring for service restoration.
Jul 15, 10:55 AM
investigating — We are investigating a service degradation affecting Grok 4.5
Investigating service degradation — Cloud Agents
minorJul 15, 10:21 AM→Jul 15, 11:31 AMresolved
Jul 15, 11:31 AM
resolved — This incident has been resolved.
Jul 15, 11:28 AM
monitoring — A fix has been implemented and we are monitoring for service restoration.
Jul 15, 10:21 AM
investigating — We are investigating a service degradation affecting Cloud Agents.
Investigating service degradation
minorJul 14, 07:52 PM→Jul 15, 09:11 AMresolved
Jul 15, 09:11 AM
resolved — This incident has been resolved.
Jul 14, 07:52 PM
investigating — We are investigating a service degradation. Some users may experience occasional low rate errors when using grok 4.5 models.
Investigating service degradation - Sol
minorJul 14, 07:55 PM→Jul 14, 08:10 PMresolved
Jul 14, 08:10 PM
resolved — This incident has been resolved.
Jul 14, 07:55 PM
investigating — This incident is now resolved.
Investigating service degradation
minorJul 13, 07:41 AM→Jul 13, 07:58 AMresolved
Jul 13, 07:58 AM
resolved — This incident has been resolved.
Jul 13, 07:41 AM
investigating — We are investigating a service degradation. Affected agent surfaces: Composer, Grok
Investigating service degradation
minorJul 13, 07:37 AM→Jul 13, 07:37 AMresolved
Jul 13, 07:37 AM
resolved — We are investigating a service degradation. Affected agent surfaces: Composer.
Incorrect Usage Amount on Dashboard
minorJul 8, 02:28 PM→Jul 8, 02:58 PMresolved
Jul 8, 02:58 PM
resolved — This incident has been resolved. Usage should display correctly in the dashboard.
Jul 8, 02:28 PM
investigating — We are investigating a service degradation affecting cursor.com, causing usage to incorrectly display as 0%
Degraded Performance for Auto
majorJul 8, 02:33 PM→Jul 8, 02:38 PMresolved
Jul 8, 02:38 PM
resolved — This incident has been resolved.
Jul 8, 02:33 PM
investigating — We are investigating a service degradation for Auto mode
Degraded Performance for Anthropic Models
majorJul 7, 09:12 PM→Jul 7, 10:25 PMresolved
Jul 7, 10:25 PM
resolved — This incident has been resolved.
Jul 7, 09:12 PM
investigating — We are investigating a service degradation for Anthropic models: https://status.claude.com/
Investigating service degradation
minorJul 6, 09:29 AM→Jul 6, 11:02 AMresolved
Jul 6, 11:02 AM
resolved — This incident has been resolved.
Jul 6, 10:40 AM
investigating — We are continuing to investigate the issue.
Jul 6, 09:29 AM
investigating — We are investigating increased latencies, with high errors for GLM 5.2.
June 2026
Elevated errors across Anthropic models
minorJun 23, 02:26 PM→Jun 23, 04:47 PMresolved
Jun 23, 04:47 PM
resolved — This incident has been resolved.
Jun 23, 03:40 PM
monitoring — A fix has been implemented and we are monitoring for service restoration.
Jun 23, 02:26 PM
investigating — We are investigating elevated errors across Anthropic Models
Investigating service degradation — Automations
majorJun 22, 04:44 AM→Jun 22, 04:53 AMresolved
Jun 22, 04:53 AM
resolved — This incident has been resolved.
Jun 22, 04:52 AM
investigating — We are currently investigating this issue. We will provide updates as more information becomes available.
Jun 22, 04:44 AM
investigating — We are investigating a service degradation affecting creating automations.
Degraded Performance for Composer 2.5
minorJun 17, 04:29 PM→Jun 17, 05:19 PMresolved
Jun 17, 05:19 PM
resolved — This incident has been resolved.
Jun 17, 05:04 PM
investigating — We are currently investigating this issue. We will provide updates as more information becomes available.
Jun 17, 04:29 PM
investigating — Degraded Performance for Composer 2.5
Investigating service degradation — Composer 2.5
majorJun 17, 09:28 AM→Jun 17, 10:20 AMresolved
Jun 17, 10:20 AM
resolved — This incident has been resolved.
Jun 17, 10:15 AM
monitoring — A fix has been implemented, stability has improved significantly and we are monitoring.
Jun 17, 09:28 AM
investigating — We are investigating an elevated error rate for composer 2.5 fast, which may affect other services, such as bugbot
Elevated errors across many models on Anthropic
majorJun 16, 06:00 PM→Jun 16, 07:41 PMresolved
Jun 16, 07:41 PM
resolved — This incident has been resolved.
Jun 16, 06:11 PM
investigating — This is resolved now
Jun 16, 06:00 PM
investigating — We are investigating elevated errors across many models on Anthropic
Investigating service degradation of the Auto model
minorJun 16, 01:04 PM→Jun 16, 01:38 PMresolved
Jun 16, 01:38 PM
resolved — This incident has been resolved.
Jun 16, 01:04 PM
investigating — We are investigating a service degradation affecting the 'Auto' routing model
Investigating service outage
minorJun 10, 07:09 PM→Jun 10, 07:46 PMresolved
Jun 10, 07:46 PM
resolved — This incident has been resolved.
Jun 10, 07:45 PM
monitoring — A fix has been implemented and we are monitoring for service restoration.
Jun 10, 07:26 PM
monitoring — A fix has been implemented, and we are monitoring for service restoration.
+3 more updates
Investigating service degradation — Cloud Agents
minorJun 10, 03:49 PM→Jun 10, 06:14 PMresolved
Jun 10, 06:14 PM
resolved — This incident has been resolved.
Jun 10, 03:51 PM
investigating — We are investigating an issue related to a third-party outage that may affect Cloud Agents, the Cursor dashboard, and GitHub integrations. More information: https://www.githubstatus.com/
Jun 10, 03:50 PM
investigating — We are continuing to investigate this issue.
+1 more updates
Investigating service degradation — Cloud Agents
minorJun 8, 11:43 PM→Jun 9, 01:31 AMresolved
Jun 9, 01:31 AM
resolved — This incident has been resolved.
Jun 8, 11:43 PM
investigating — We are investigating reports of elevated error rates for Cloud Agents.
Degraded Performance for Agent Sessions
criticalJun 2, 06:02 PM→Jun 2, 06:42 PMresolved
Jun 2, 06:42 PM
resolved — This incident has been resolved.
Jun 2, 06:41 PM
monitoring — We identified that Composer 2.5 was the only impacted model. A fix has been implemented and we are monitoring for service restoration.
Jun 2, 06:02 PM
investigating — We are investigating a service degradation affecting CLI, Cloud Agents, and IDE.
May 2026
Cloud Agents degradation
majorMay 30, 06:31 AM→May 30, 07:09 AMresolved
May 30, 07:09 AM
resolved — This incident has been resolved.
May 30, 06:56 AM
monitoring — A fix has been implemented and we are monitoring the results.
May 30, 06:51 AM
identified — The issue has been identified and a fix is being implemented.
+1 more updates
Composer 2.5 Fast degradation
minorMay 27, 03:38 PM→May 27, 08:12 PMresolved
May 27, 08:12 PM
resolved — This incident has been resolved.
May 27, 06:13 PM
monitoring — A fix has been implemented and Composer 2.5 Fast service has stabilized. We are monitoring for service restoration.
May 27, 04:12 PM
investigating — We are continuing to investigate this issue. We will provide updates as more information becomes available.
+1 more updates
Degraded Performance for Composer 2
criticalMay 27, 11:34 AM→May 27, 11:49 AMresolved
May 27, 11:49 AM
resolved — This incident has been resolved.
May 27, 11:34 AM
investigating — We are investigating a service degradation.
Investigating service degradation for Composer 2.5
minorMay 27, 09:21 AM→May 27, 09:26 AMresolved
May 27, 09:26 AM
resolved — This incident has been resolved.
May 27, 09:21 AM
investigating — We are seeing a drop in availability for Composer-2.5 and are investigating
Investigating Service Degradation in AI Features
minorMay 27, 06:39 AM→May 27, 06:54 AMresolved
May 27, 06:54 AM
resolved — This incident has been resolved.
May 27, 06:39 AM
investigating — We are investigating a service degradation affecting AI features, including Agent mode.
Degraded user summarizations and Gemini 2.5 Flash
minorMay 26, 06:07 PM→May 26, 07:07 PMresolved
May 26, 07:07 PM
resolved — This incident has been resolved.
May 26, 06:07 PM
investigating — We are investigating a service degradation affecting Gemini 2.5 Flash and user summarizations.
Degraded Performance for Agent Sessions
minorMay 26, 03:04 AM→May 26, 07:11 AMresolved
May 26, 07:11 AM
resolved — This incident has been resolved.
May 26, 03:47 AM
monitoring — A fix has been implemented and we are monitoring for service restoration.
May 26, 03:04 AM
investigating — We are monitoring a service degradation affecting Agents sessions in IDE
Composer 2.5 Fast Service Degradation
minorMay 24, 05:41 PM→May 24, 06:49 PMresolved
May 24, 06:49 PM
resolved — This incident has been resolved.
May 24, 05:41 PM
investigating — We are investigating a service degradation on Composer 2.5 Fast.
Investigating service degradation of Composer 2.5 Fast
minorMay 24, 04:46 PM→May 24, 05:26 PMresolved
May 24, 05:26 PM
resolved — This incident has been resolved.
May 24, 04:46 PM
investigating — We are investigating a service degradation of Composer 2.5 Fast.
Degraded agent performance on Composer 2.5 / Auto requests
minorMay 21, 12:25 PM→May 21, 03:31 PMresolved
May 21, 03:31 PM
resolved — This incident has been resolved.
May 21, 02:59 PM
monitoring — A fix has been implemented and we are monitoring for service restoration.
May 21, 02:58 PM
identified — The root cause has been identified and a fix is being implemented.
+1 more updates
Related Incident Histories
Get Cursor Outage Alerts
Be the first to know when Cursor go down.