OpenAI Outage History
25 incidents reported. Data sourced from the official OpenAI status page.
25
Total Incidents
5
Major/Critical
18
Minor
25
Resolved
July 2026
Enterprise & Education Chat Errors
noneJul 31, 09:04 AM→Jul 31, 09:28 AMresolved
Jul 31, 09:28 AM
resolved — This is now resolved.
Jul 31, 09:06 AM
monitoring — The issue has been mitigated.
Jul 31, 09:05 AM
identified — We have identified that some ChatGPT Business and Education users are experiencing elevated errors when starting or continuing conversations. We are working on implementing a mitigation and will provi...
+1 more updates
Elevated errors affecting ChatGPT conversations
minorJul 30, 02:35 PM→Jul 30, 04:01 PMresolved
Jul 30, 04:01 PM
resolved — All impacted services have now fully recovered.
Jul 30, 03:26 PM
monitoring — We have applied the mitigation and are monitoring the recovery.
Jul 30, 02:53 PM
monitoring — We have applied the mitigation and are monitoring the recovery.
+1 more updates
Elevated error rates with the invalid_prompt error code
minorJul 29, 12:55 AM→Jul 29, 02:20 AMresolved
Jul 29, 02:20 AM
resolved — All impacted services have now fully recovered.
Jul 29, 01:39 AM
monitoring — We have applied the mitigation and are monitoring the recovery.
Jul 29, 12:55 AM
investigating — We are investigating the issue for the listed services.
Elevated Image Generation Error Rate in ChatGPT
minorJul 28, 02:39 PM→Jul 28, 03:15 PMresolved
Jul 28, 03:15 PM
resolved — All impacted services have now fully recovered.
Jul 28, 03:13 PM
monitoring — We have applied the mitigation and are monitoring the recovery.
Jul 28, 02:39 PM
identified — We have identified that users are experiencing elevated errors for the impacted services.
We are working on implementing a mitigation.
Image generation unavailable in ChatGPT
minorJul 27, 07:05 PM→Jul 27, 08:24 PMresolved
Jul 27, 08:24 PM
resolved — All impacted services have now fully recovered.
Jul 27, 07:05 PM
investigating — We have identified that users are experiencing elevated errors for the impacted services.
We are working on implementing a mitigation.
Image generation unavailable in ChatGPT
majorJul 21, 10:36 AM→Jul 22, 02:50 AMresolved
Jul 27, 07:04 PM
resolved — All impacted services have now fully recovered.
Jul 27, 04:52 PM
investigating — We have identified that users are experiencing elevated errors for the impacted services.
We are working on implementing a mitigation.
Jul 27, 02:04 PM
investigating — We have identified that users are experiencing elevated errors for the impacted services.
We are working on implementing a mitigation.
+12 more updates
We’re seeing elevated latency, timeouts, and interrupted streaming across gpt 5.1 mini model and gpt 4.1 mini
minorJul 27, 06:06 PM→Jul 27, 05:30 PMresolved
Jul 27, 08:52 PM
resolved — All impacted services have now fully recovered.
Jul 27, 06:06 PM
investigating — We are investigating the issue for the listed services.
Elevated errors affecting ChatGPT conversations
minorJul 25, 10:09 PM→Jul 27, 04:32 PMresolved
Jul 27, 04:32 PM
resolved — All impacted services have now fully recovered.
Jul 25, 11:57 PM
monitoring — Mitigation has been implemented, and we are monitoring the recovery of ChatGPT conversations.
Jul 25, 11:16 PM
identified — We have identified the source of intermittent errors affecting some ChatGPT conversations and are working to mitigate the issue. Error rates have decreased, but some users may continue to experience f...
+1 more updates
Elevated error rates
minorJul 25, 11:35 AM→Jul 25, 11:57 AMresolved
Jul 25, 11:57 AM
resolved — All impacted services have now fully recovered.
Jul 25, 11:46 AM
monitoring — We have applied the mitigation and are monitoring the recovery.
Jul 25, 11:35 AM
identified — We have identified that users are experiencing elevated errors for the impacted services.
We are working on implementing a mitigation.
Elevated error rates
minorJul 25, 09:17 AM→Jul 25, 11:08 AMresolved
Jul 25, 11:08 AM
resolved — All impacted services have now fully recovered.
Jul 25, 10:02 AM
monitoring — We have applied the mitigation and are monitoring the recovery.
Jul 25, 09:17 AM
investigating — We are investigating the issue for the listed services.
Elevated Error Rates
minorJul 23, 03:36 PM→Jul 24, 07:33 PMresolved
Jul 24, 07:33 PM
resolved — All impacted services have now fully recovered.
Jul 24, 11:34 AM
monitoring — We have applied the mitigation and are monitoring the recovery.
Jul 24, 10:06 AM
investigating — We are investigating the issue for the listed services.
+10 more updates
Elevated Errors in Codex Review
minorJul 24, 07:55 AM→Jul 24, 09:35 AMresolved
Jul 24, 09:35 AM
resolved — All impacted services have now fully recovered.
Jul 24, 08:11 AM
monitoring — We have applied the mitigation and are monitoring the recovery.
Jul 24, 07:55 AM
investigating — We are investigating the issue for the listed services.
Elevated API error rates and latency on gpt-image-2 model
minorJul 23, 11:56 PM→Jul 24, 12:09 AMresolved
Jul 24, 12:09 AM
resolved — All impacted services have now fully recovered.
Jul 23, 11:56 PM
identified — We have identified that users are experiencing elevated errors for the impacted services.
We are working on implementing a mitigation.
Some users may experience elevated error rates in ChatGPT
minorJul 23, 05:56 PM→Jul 23, 08:41 PMresolved
Jul 23, 08:41 PM
resolved — All impacted services have now fully recovered.
Jul 23, 06:22 PM
monitoring — We have applied the mitigation and are monitoring the recovery.
Jul 23, 05:56 PM
identified — We have identified that users are experiencing elevated errors for the impacted services.
We are working on implementing a mitigation.
Elevated errors for Workspace Agent
minorJul 22, 02:48 PM→Jul 22, 04:09 PMresolved
Jul 22, 04:09 PM
resolved — All impacted services have now fully recovered.
Jul 22, 03:49 PM
identified — We have identified that users are experiencing elevated errors for the impacted services.
We are working on implementing a mitigation.
Jul 22, 02:48 PM
investigating — We are investigating the issue for the listed services.
Elevated Errors Affecting File Uploads and Image Generation
minorJul 22, 07:32 AM→Jul 22, 02:39 PMresolved
Jul 22, 02:39 PM
resolved — All impacted services have now fully recovered.
Jul 22, 09:44 AM
monitoring — We have applied the mitigation and are monitoring the recovery.
Jul 22, 09:26 AM
identified — We have identified that users are experiencing elevated errors for the impacted services.
We are working on implementing a mitigation.
+2 more updates
Elevated errors for API image generation
majorJul 21, 07:33 PM→Jul 21, 10:19 PMresolved
Jul 21, 10:19 PM
resolved — Image generation functionality has fully recovered, and error rates have returned to normal levels.
Jul 21, 08:26 PM
monitoring — We have applied mitigations and are seeing error rates return to normal levels. We are monitoring the recovery.
Jul 21, 07:33 PM
investigating — We are investigating elevated error rates affecting image generation requests via the API. We are working to restore normal service.
Issues with logins and signups
majorJul 21, 06:36 PM→Jul 21, 07:00 PMresolved
Jul 21, 07:00 PM
resolved — All affected API Platform functionality has now fully recovered.
Jul 21, 06:56 PM
monitoring — The affected API Platform functionality has recovered, including login, account creation, organization management, and dashboard access. We are monitoring the recovery.
Jul 21, 06:41 PM
identified — We are seeing recovery for API Platform login functionality. Account creation, organization management, and dashboard access remain affected. We are continuing to investigate.
+1 more updates
Elevated errors for GitHub-dependent ChatGPT and Codex workflows
minorJul 20, 12:34 AM→Jul 20, 03:34 AMresolved
Jul 20, 03:34 AM
resolved — All impacted services have now fully recovered.
Jul 20, 03:25 AM
monitoring — We are monitoring the recovery.
Jul 20, 02:52 AM
investigating — Users may experience failures or delays in ChatGPT and Codex workflows that depend on GitHub. This mostly should impact Codex web and code review for PRs on Github. This is related to an active GitHub...
+3 more updates
Elevated errors affecting ChatGPT
majorJul 19, 02:49 PM→Jul 19, 05:05 PMresolved
Jul 19, 05:05 PM
resolved — All impacted services have now fully recovered.
Jul 19, 04:55 PM
monitoring — Service has been restored and we are continuing to monitor.
Jul 19, 03:04 PM
monitoring — We have applied the mitigation and are monitoring the recovery.
+2 more updates
Some users are unable to access Codex
minorJul 18, 08:05 AM→Jul 18, 12:58 PMresolved
Jul 18, 12:58 PM
resolved — All impacted services have now fully recovered.
Jul 18, 08:31 AM
monitoring — We have applied the mitigation and are monitoring the recovery.
Jul 18, 08:05 AM
identified — We have identified an issue causing some users to receive access-denied errors when using the Codex desktop app and CLI.
New ChatGPT App Not Available For Enterprise Users Without Codex Permissions
majorJul 17, 03:32 PM→Jul 18, 05:45 AMresolved
Jul 18, 08:24 AM
resolved — All impacted services have now fully recovered.
Jul 18, 07:43 AM
identified — We have identified that this issue has recurred for some Enterprise users. We are working to resolve this.
Jul 18, 05:45 AM
resolved — A fix has been released. Please update to the latest version of the ChatGPT app to receive the fix.
+1 more updates
Codex 5.6-sol Experiencing Increased Server-Overload Errors
noneJul 17, 05:19 PM→Jul 17, 08:42 PMresolved
Jul 17, 08:42 PM
resolved — All impacted services have now fully recovered.
Jul 17, 07:07 PM
monitoring — We have applied the mitigation and are monitoring the recovery.
Jul 17, 05:19 PM
identified — We have identified that users are experiencing elevated errors for the impacted services.
We are working on implementing a mitigation.
Elevated errors for Github connector
minorJul 16, 10:54 PM→Jul 17, 12:17 AMresolved
Jul 17, 12:17 AM
resolved — All impacted services have now fully recovered.
Jul 16, 11:12 PM
identified — We have identified that users are experiencing elevated errors when using the Github connector.
Github is experiencing system-wide service-availability issues. We are monitoring their recovery: <http...
Jul 16, 10:54 PM
identified — We have identified that users are experiencing elevated errors when using the Github connector.
We are working on implementing a mitigation.
Elevated Error Rates For SSO Login
minorJul 16, 08:36 AM→Jul 16, 03:23 PMresolved
Jul 16, 03:23 PM
resolved — All impacted services have now fully recovered.
Jul 16, 10:57 AM
monitoring — We have applied the mitigation and are monitoring the recovery.
Jul 16, 09:59 AM
investigating — We are investigating the issue for the listed services and seeing gradual recovery.
+1 more updates
Related Incident Histories
Get OpenAI Outage Alerts
Be the first to know when OpenAI go down.